Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2021, 03:02

Обращение к реквизиту формы

Автор BlackWolf, 26 апр 2017, 15:38

0 Пользователей и 1 гость просматривают эту тему.

BlackWolf

Здравствуйте не получается вытащить значение реквизита "АдресДоставки" из ФормыДокумента, что делаю не так? :dfbsdfbsdf:

Процедура ДобавитьНажатие(Элемент)
    ВыбЭлемент = Документы.РеализацияТоваровУслуг.ПолучитьФормуВыбора();
    ВыбранныйДокумент = ВыбЭлемент.ОткрытьМодально();
    Если ВыбранныйДокумент = Неопределено Тогда
        Сообщить("Не выбрана реализация");
    Иначе
    ВыбЗначение = ВыбранныйДокумент;   
    Форма = ВыбЗначение.ПолучитьФорму("ФормаДокумента");   
Для Каждого ТекСтрокаТовары Из ВыбЗначение.Товары Цикл
НоваяСтрока = Товары.Добавить();
НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаТовары.ЕдиницаИзмерения;
НоваяСтрока.ЗаказПокупателя  = ТекСтрокаТовары.ЗаказПокупателя;
НоваяСтрока.Количество       = ТекСтрокаТовары.Количество;
НоваяСтрока.Номенклатура     = ТекСтрокаТовары.Номенклатура;
            НоваяСтрока.АдресДоставки    = Форма.ЭлементыФормы.АдресДоставки.Значение;     
            НоваяСтрока.Контрагент       = Форма.ЭлементыФормы.Контрагент.Значение;           
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры


ilyay

Посмотрите в визуальном компоненте на форме поле ПутьКДанным. Оттуда и тяните.

BlackWolf


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск