Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос по Задолженности Дт, Кт  (Прочитано 7421 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Элен62

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Программист 1С
Подскажите, я формирую отчет, который должен выводить Задолженность -2 колонки Дт и Кт.  Известен Контрагент, номер Договора, Сумма Договора, Фактическая сумма по актам, Оплата ( по 62 счету берется), и Остаток по договору и Итог уже есть. А как задолженность вытащить. Из Каких регистров брать? 90 счет. Хозрасчетный/Обороты.....? что еще вытащить? Вот запрос из моего кода. Подскажите пожалуйста, а то с бухгалтерией проблемки)).

ВЫБРАТЬ
                  |   ХозрасчетныйОбороты.Организация,
                  |   ХозрасчетныйОбороты.Субконто1 КАК Контрагент,
                  |   ХозрасчетныйОбороты.Субконто2.Родитель КАК ГруппаДоговора,
                  |   ХозрасчетныйОбороты.Субконто2 КАК Договор,
                  |   ХозрасчетныйОбороты.Субконто2.Комментарий КАК СуммаДоговора,
                  |   ХозрасчетныйОбороты.СуммаОборотКт КАК СуммаАванса
                  |ИЗ
                  |   РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет1), , , , ) КАК ХозрасчетныйОбороты";
   


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
В самом простом случае, если остаток по 62.01 это ваша дебиторка, если остаток по 62.02 - это аванс вам от покупателя, т.е. кредиторка.

Оффлайн Элен62

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Программист 1С
а вот так программно правильно будет?
Процедура СформироватьЗапрос(ТаблицаЗапроса)
ТекстУсловия3 = "";
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Счет1", ПланыСчетов.Хозрасчетный.НайтиПоКоду("62"));
    Запрос.УстановитьПараметр("Счет2", ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01"));
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Если ЗначениеЗаполнено(ДатаНач) Тогда
Граница = Новый Граница(НачалоДня(ДатаНач), ВидГраницы.Включая);
Запрос.УстановитьПараметр("НачалоПериода", Граница.Значение);
Иначе
Запрос.УстановитьПараметр("НачалоПериода", Дата('00010101000000'));
КонецЕсли;
Если ЗначениеЗаполнено(ДатаКон) Тогда
Граница = Новый Граница(КонецДня(ДатаКон), ВидГраницы.Включая);
Запрос.УстановитьПараметр("КонецПериода", Граница.Значение);
Иначе
Граница = Новый Граница(КонецДня(ТекущаяДата()), ВидГраницы.Включая);
Запрос.УстановитьПараметр("КонецПериода", Граница.Значение);
КонецЕсли;
Запрос.Текст = "ВЫБРАТЬ
              | ХозрасчетныйОбороты.СуммаОборотДт,
  | ХозрасчетныйОбороты.СуммаОборотКт,
                   | ХозрасчетныйОбороты.Организация,
              | ХозрасчетныйОбороты.Субконто1 КАК Контрагент,
              | ХозрасчетныйОбороты.Субконто2.Родитель КАК ГруппаДоговора,
              | ХозрасчетныйОбороты.Субконто2 КАК Договор,
              | ХозрасчетныйОбороты.Субконто2.Комментарий КАК СуммаДоговора
              |ИЗ
              | РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет1), , , , ) КАК ХозрасчетныйОбороты";
  |РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет2), , , , ) КАК ХозрасчетныйОбороты";
Если Организация <> Справочники.Организации.ПустаяСсылка() Тогда
ТекстУсловия1 = "
|   ГДЕ
              | ХозрасчетныйОбороты.Организация = &Организация";
Иначе
ТекстУсловия1 = "";
КонецЕсли;
Если Контрагент = Справочники.Контрагенты.ПустаяСсылка() Тогда
ТекстУсловия2 = "";
Иначе
Если ТекстУсловия1 <> "" Тогда
ТекстУсловия2 = "
| И ХозрасчетныйОбороты.Субконто1 = &Контрагент";
Иначе
ТекстУсловия2 = "
|   ГДЕ
              | ХозрасчетныйОбороты.Субконто1 = &Контрагент";
КонецЕсли;
КонецЕсли;
Запрос.Текст = Запрос.Текст + ТекстУсловия1 + ТекстУсловия2 + ТекстУсловия3;
ТаблицаЗапроса = Запрос.Выполнить().Выгрузить();
КонецПроцедуры
Вот не понимаю я тогда, про какой 90й счет мне клиенты говорят тогда?

Последний раз редактировалось: progmikon; 01 Мар 2011, 15:40

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
на 90 счете отражаются ваши продажи.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А зачем вот эта конструкция
|РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет1), , , , ) КАК ХозрасчетныйОбороты";
|РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет2), , , , ) КАК ХозрасчетныйОбороты";

Оффлайн Элен62

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Программист 1С
Это для дальнейшей подвязки кода. Могу скинуть отчетик на почту, здесь к сожалению папка загрузки не работает((.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
К вечеру должны вложения заработать.

Оффлайн Элен62

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Программист 1С
Было бы здорово, а то так уже с недельку отправить не могу). Тогда выложу вечером. Пока почитаю теорию.

Оффлайн Элен62

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Программист 1С
прикладываю ведомость (внешний отчет)

Оффлайн Элен62

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Программист 1С
В колонках Дт и Кредит не считается, т.к. не знаю к чему обращаться конкретно. Хозрасчетный/... Заранее спасибо)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 151
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal