Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 08:23
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Отправка смс  (Прочитано 1325 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kerbert

  • *
  • Регистрация: 2017-04-24
  • Сообщений: 46
  • РЕПУТАЦИЯ: 4
  • КПД: 9%
  • Профессия: Программист 1С
Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ВнешняяОбработка.СервисMTSSMS.МодульОбъекта(32)}: Ошибка при вызове метода контекста (SendMessage)
      СтруктураОтветаWSПрокси = Прокси.SendMessage(ПолучательSMS.НомерТелефона,ТекстSMS,Подпись,Пользователь,Пароль);
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка вызова операции сервиса:  {http://mcommunicator.ru/M2M}:MTS_x0020_Communicator_x0020_M2M_x0020_XML_x0020_API:SendMessage()
по причине:
SOAP сервера:  no SOAPAction header!Код ошибки: Client.NoSOAPActionДанная ошибка происходит при выполнении запросов к веб-сервису.Ошибка ...">При вызове веб-сервиса произошла ошибка. Ошибка SOAP сервера:  INCORRECT_PASSWORD
Код ошибки: Client
Источник ошибки: http://www.mcommunicator.ru/m2m/m2m_api.asmx
Техническая информация:
<detail xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <code xmlns="http://mcommunicator.ru/M2M/">103</code>
   <description xmlns="http://mcommunicator.ru/M2M/">INCORRECT_PASSWORD</description>
</detail>
Вылетает такая штука ,учитывая что данные вводятся все правильно.
Часть кода где ошибка :
Функция ОтправитьSMS(ТекстSMS, ПолучателиSMS, ВыдаватьСообщенияОбОшибке = Истина) Экспорт
   Результат = Ложь;
   
   // Инициализируем данные
   Прокси = ПолучитьПроксиWSDL(ВыдаватьСообщенияОбОшибке);
   Если Прокси = Неопределено Тогда
      Возврат Результат;
   КонецЕсли;
                           
   Для Каждого ПолучательSMS Из ПолучателиSMS Цикл
      
      // Отправляем и получаем ответ от сервера
      СтруктураОтветаWSПрокси = Прокси.SendMessage(ПолучательSMS.НомерТелефона,ТекстSMS,Подпись,Пользователь,Пароль);
      
      // Разбираем структуру ответа
      Если РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Действие = 0 Тогда
         ПолучательSMS.IDСообщения = СтрЗаменить(Строка(СтруктураОтветаWSПрокси.MessageStatusWithID), " ", "");
         Результат = Истина;
      Иначе
         ПолучательSMS.СтатусСообщения = РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Текст;
         ПолучательSMS.СтатусДействия  = РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Действие;         
         Если ВыдаватьСообщенияОбОшибке Тогда
            Сообщить(РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Текст);
         КонецЕсли;
      КонецЕсли;
      
   КонецЦикла;
   
   Возврат Результат;
КонецФункции


Оффлайн Dethmontt

  • Денис
  • *****
  • Регистрация: 2010-11-01
  • Сообщений: 2892
  • РЕПУТАЦИЯ: 552
  • КПД: 19%
  • Адын Эс
  • Профессия: Программист 1С
Re: Отправка смс
« Ответ #1: 25 Апр 2017, 10:17 »
INCORRECT_PASSWORD
Собственно ответ...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
22 Сообщений
SSC
15 Сообщений
alexandr_ll
15 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 156
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск