Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Сен 2019, 10:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.  (Прочитано 1300 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ZSS

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-29
  • Сайт: 
Конфигурация Медицина.Больничная аптека. редакция 1.1.8.1 платформа 8.3.9.2170
ТабДокумент = Новый ТабличныйДокумент;
   ПолноеИмяМакета = МассивОбъектов[0].Метаданные().ПолноеИмя() + ".ПечатьШтрихКода";
   ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ"+ ПолноеИмяМакета;;
   
   Макет = УправлениеПечатью.ПолучитьМакет(ПолноеИмяМакета);
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ШтрихкодыНоменклатуры.Штрихкод,
   |   ОтпускТоваровВОтделениеТовары.Номенклатура
   |ИЗ
   |   Документ.ОтпускТоваровВОтделение.Товары КАК ОтпускТоваровВОтделениеТовары
   |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры
   |      ПО ОтпускТоваровВОтделениеТовары.Номенклатура = ШтрихкодыНоменклатуры.Номенклатура
   |         И ОтпускТоваровВОтделениеТовары.ЕдиницаИзмерения = ШтрихкодыНоменклатуры.ЕдиницаИзмерения
   |ГДЕ
   |   ОтпускТоваровВОтделениеТовары.Ссылка В(&Ссылка)
   |   И НЕ ШтрихкодыНоменклатуры.Штрихкод ЕСТЬ NULL ";
   
   Запрос.УстановитьПараметр("Ссылка",МассивОбъектов);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   Выборка = РезультатЗапроса.Выбрать();
   ОбластьМакета = Макет.ПолучитьОбласть("Строка|Столбец");
   ЧетНечет = 0;
   Нумератор = 0;
   
   ВнешняяКомпонента = ПодключитьВнешнююКомпонентуПечатиШтрихкода();
   
   Пока Выборка.Следующий() Цикл
      НомерСтрокиНачало = ТабДокумент.ВысотаТаблицы + 1;
      ОбластьМакета.Параметры.Номенклатура = Выборка.Номенклатура;
      Картинка = ПолучитьКартинкуШтрихкода(ВнешняяКомпонента,Выборка.ШтрихКод,Неопределено,Неопределено);
      ОбластьМакета.Рисунки.ШтрихКод.Картинка = Картинка;            
      
      Если (ЧетНечет/2-Цел(ЧетНечет/2))= 0 Тогда
         ТабДокумент.Вывести(ОбластьМакета);
      Иначе   
         ТабДокумент.Присоединить(ОбластьМакета);      
      КонецЕсли;
      ЧетНечет = ЧетНечет + 1;
      Нумератор = Нумератор + 1;
      Если Нумератор = 8 Тогда
         ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
         Нумератор = 0;
      КонецЕсли;
      
      УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДокумент, НомерСтрокиНачало, ОбъектыПечати, МассивОбъектов);
      
   КонецЦикла;
   
   ТабДокумент.ОтображатьСетку = Ложь;
   ТабДокумент.АвтоМасштаб = Истина;
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
      
   
   Возврат ТабДокумент;

Процедура ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, НомерСтрокиНачало, ОбъектыПечати, Ссылка) Экспорт
   
   Элемент = ОбъектыПечати.НайтиПоЗначению(Ссылка);
   Если Элемент = Неопределено Тогда
      ИмяОбласти = "Документ_" + Формат(ОбъектыПечати.Количество() + 1, "ЧН=; ЧГ=");
      ОбъектыПечати.Добавить(Ссылка, ИмяОбласти);
   Иначе
      ИмяОбласти = Элемент.Представление;
   КонецЕсли;
   
   НомерСтрокиОкончание = ТабличныйДокумент.ВысотаТаблицы;
   ТабличныйДокумент.Область(НомерСтрокиНачало, , НомерСтрокиОкончание, ).Имя = ИмяОбласти;

КонецПроцедуры

В отладчике все области видит но почему то на принтер выходит только 1 область вторая не выходит на притер??что может быть подскажите?


Оффлайн TytovV

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 5
  • КПД: 4%
  • Регистрация: 2014-10-28
  • Сайт: 
  • Профессия: Программист 1С
У вас в цикле речь идет только об одной ОбластьМакета.Рисунок.ШтрихКод где описание остальных картинок штрих кодов. Даже в присодинении области нет ни слова что вы еще присодиняете при следующем проходе такую же область картинка. Причем далее в условие Если вы сразу выводите вывести(областьмакета) так как ваше выражение в скобках 0-0 =0 это что за арифметика вы наверное хотели остаток от 0 таким образом вычесть. Пересмотрите это кусочек, у при следующем проходе цикла должна присоединится следующая область картинка.


Отправлено с моего iPhone используя Tapatalk

Оффлайн ZSS

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-29
  • Сайт: 
Когда делаешь через предворительный просмотр,печатаются 3 штрих кода.Кто нибудь знает в чем может быть причина?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
92 Сообщений
LexaK
53 Сообщений
alexandr_ll
41 Сообщений
Yamuna
35 Сообщений
KOI8-R
27 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
BuhRust
21 Сообщений
DmitriyF DmitriyF
19 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений

* Кто онлайн

  • Точка Гостей: 617
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal