Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 07:39

как сделать не доступными

Автор saha85, 22 апр 2017, 08:22

0 Пользователей и 1 гость просматривают эту тему.

saha85

Документ
Реквизит(ПереключалкаДаНетБулево)=Булево
Реквизит(ВиденТолькоКогдаВкл)= Дата
Реквизит(ВиденТолькоКогдаВкл2)=Строка

Когда форму открываем они не доступны но как я выбираю "Да" они становится доступны.
Если не трудно ПРИМЕР КАК ЕГО СДЕЛАТЬ

saha85

Цитата: saha85 от 22 апр 2017, 08:22
Документ
Реквизит(ПереключалкаДаНетБулево)=Булево
Реквизит(ВиденТолькоКогдаВкл)= Дата
Реквизит(ВиденТолькоКогдаВкл2)=Строка

Когда форму открываем они не доступны но как я выбираю "Да" они становится доступны.
Если не трудно ПРИМЕР КАК ЕГО СДЕЛАТЬ
Пока ждал сам разобрался вот код
Цитировать&НаКлиенте
Процедура ПриОткрытии(Отказ)
Элементы.ДатаПер.Видимость=Ложь;
КонецПроцедуры
&НаКлиенте
Процедура ПереведенПриИзменении(Элемент)
   Если  Элементы.Переведен.Видимость=Истина Тогда
      Элементы.ДатаПер.Видимость=Истина;
      Элементы.Перевод1.Видимость=Истина;
      Объект.ДатаПер = ТекущаяДата();
   КонецЕсли
КонецПроцедуры
Лудще подскажите как строку превратить в булево в Модуле
Вот
Цитировать&НаКлиенте
Процедура РезультатБакПриИзменении(Элемент)
      Если Строка(Объект.РезультатБак) = "Не взят" Тогда
      Элементы.Ислед.Видимость=Ложь;
   ИначеЕсли Строка(Объект.РезультатБак) = "Взят" Тогда
      Элементы.Ислед.Видимость=Истина;
   КонецЕсли
КонецПроцедуры

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск