Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 06:35

Передать значение адреса объекта с клиента на сервер

Автор Gigi Spoke, 20 апр 2017, 15:05

0 Пользователей и 1 гость просматривают эту тему.

Gigi Spoke

Всем привет уважаемые форумчане и специалисты!
Гуууу!
Сколько уже вожусь и никак не получается...перерыл везде, где мог и ничего не нашел, как сделать следующее:
Допустим есть справочник: "ОБЪЕКТ". И нужно, что бы из формы этого справочника по указанному адресу был найден указанный код реквизита на сервере, но в другом справочнике, на пример в списке справочника "ТОЧКА". Для чего есть команда: "НайтиПоКоду". И вроде бы с этим все получилось по вот такой схеме:

&НаКлиенте
Процедура Тест_Пойск(Команда)
ТекстКода="000000001";
ПолучитьКод(ТекстКода);
КонецПроцедуры

&НаСервере
Процедура ПолучитьКод(ТекстПойска)
Путь = Справочники.ТОЧКА;
Строка = Путь.НайтиПоКоду(ТекстПойска);
Сообщить(Строка.Наименование);
КонецПроцедуры


Сразу скажу, что с 1С подружился совсем недавно, и поэтому обращаюсь за помощь
Как видно из выше указанного кода. "ТекстКода" задан на клиенте и передан на сервер.
И система вроде нормально реагирует и находит. Но как только сам адрес поиска: "Справочники.ТОЧКА" указываешь на клиенте. На пример так:

НаКлиенте
Процедура Тест_Пойск(Команда)
Адрес= Справочники.ТОЧКА;
ТекстКода="000000001";
ПолучитьКод(Адрес, ТекстКода);
КонецПроцедуры

&НаСервере
Процедура ПолучитьКод(Путь, ТекстПойска)
Строка = Путь.НайтиПоКоду(ТекстПойска);
Сообщить(Строка.Наименование);
КонецПроцедуры


СИСТЕМА ТУТ ЖЕ НАЧИНАЕТ РУГАТЬСЯ!

Ну это понятное дело почему! Догадываюсь, что нужно создать объект. Но че то не выходит.
Пробовал разные варианты как перемененную: "Путь" передать с клиента на сервер, но ни в какую!

Поэтому очень прошу, если можно, подкорректировать и помочь как это сделать!

БУДУ ОЧЕНЬ ПРИЗНАТЕЛЕН ЗА ПОМОЩЬ!

ilyay


&НаКлиенте
Процедура Тест_Поиск(Команда)
Адрес= "ТОЧКА";
ТекстКода="000000001";
ПолучитьКод(Адрес, ТекстКода);
КонецПроцедуры

&НаСервере
Процедура ПолучитьКод(Путь, ТекстПоиска)
Строка = Справочники[Путь].НайтиПоКоду(ТекстПоиска);
Сообщить(Строка.Наименование);
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск