Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 05:37

Печать многостраничных файлов из внешней папки

Автор Гайдар, 14 апр 2017, 15:59

0 Пользователей и 1 гость просматривают эту тему.

Гайдар


Здравствуйте!

Процедура ниже печатает справки прикрепленные к кодам серий номенклатуры из Реализации товаров, но есть и многостраничные файлы, 1с выводит теолько первую страницу таких файлов для печати, кто знает как вывести все страницы многостраничных TIF-ов?

Процедура ОсновныеДействияФормыПечатьPDF(Кнопка)
   
     Путь = "D:\Сканы TIFF\";
     ТипФайла = ".Tif";
     ТабДок =  Новый ТабличныйДокумент;     
     Для каждого стр из Товары цикл
        Если ЗначениеЗаполнено(стр.СерияНоменклатуры) Тогда
                       
              Макет = ПолучитьМакет("МакетКартинки");
               ОбластьКартинки = Макет.ПолучитьОбласть("ОбластьКартинка");
             Попытка
             Картинка = Новый Картинка(Путь+стр.СерияНоменклатуры.Код+ТипФайла);
               ОбластьКартинки.Рисунки.D1.Картинка = Картинка;
             ТабДок.Вывести(ОбластьКартинки);    
              Исключение
             Сообщить("Строка №"+Стр.НомерСтроки+": "+ "не обнаружена справка" +" "+"для"+" "+стр.Номенклатура+", "+"код серии:"+" "+стр.СерияНоменклатуры.Код);
             Продолжить;
              КонецПопытки;
          КонецЕсли;
      КонецЦикла;
      ТабДок.Показать();
КонецПроцедуры

Dethmontt

Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Гайдар


Гайдар


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск