Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 17:17
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Ошибка: "Метод объекта не обнаружен (сумма)" в пользовательском режиме  (Прочитано 1901 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jylik_88

  • *
  • Регистрация: 2017-04-13
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
:( :dfbsdfbsdf:

1C 8.3 УТ 11.1

Подскажите, пожалуйста...
В пользовательском режиме выходит ошибка "Метод объекта не обнаружен (сумма)".
Я начинающий программист и не могу понять в чем ошибка :dfbsdfbsdf:

&НаСервере
Процедура ВыгрузитьПННаСервере()
   //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   СУММА(ПоступлениеТоваровУслугТовары.Количество) КАК Количество,
      |   СУММА(ПоступлениеТоваровУслугТовары.Сумма) КАК Сумма
      |ИЗ
      |   Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
      |ГДЕ
      |   ПоступлениеТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачалоПериода И &КонецПериода
      |   И ПоступлениеТоваровУслугТовары.Ссылка.Проведен";
   
   Запрос.УстановитьПараметр("КонецПериода", период.ДатаОкончания);
   Запрос.УстановитьПараметр("НачалоПериода", период.ДатаНачала);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            
История = Новый Массив;
Запись = Новый Структура;
Запись.Вставить("Количество", ВыборкаДетальныеЗаписи.количество);
Запись.Вставить("Сумма", ВыборкаДетальныеЗаписи.сумма);
История.Добавить(Запись);

КонецЦикла;


   //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

КонецПроцедуры

&НаКлиенте
Процедура ВыгрузитьПН(Команда)
   ВыгрузитьПННаСервере();
КонецПроцедуры


Онлайн LexaK

  • *****
  • Регистрация: 2012-05-16
  • Сообщений: 2570
  • РЕПУТАЦИЯ: 824
  • КПД: 32%
  • Профессия: Программист 1С
в этом коде ошибок нет, посмотрите подробное описание ошибки, как правило там указывается модуль и номер строки кода где возникла ошибка и еще сама строка кода, вот эту строку и надо смотреть.
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Оффлайн Igmok

  • *
  • Регистрация: 2017-04-10
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Если речь идет о пользовательском режиме - проверьте, точно этот метод прописан в форме "в действиях".
Ошибка говорит о том, для действия не найдена функция, процедура или метод. Если я верно понял.


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 8571
Последний ответ 20 Мар 2018, 16:54
от alex0402
Какие преимущества получит менеджмент компании, сменив программу "1С:Торговля и

Автор БоняРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4544
Последний ответ 25 Июл 2008, 09:35
от Боня
установка скидок в 1с 8.2 управление торговлей для Украины"

Автор FADINAРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3757
Последний ответ 03 Фев 2014, 18:08
от FADINA
В ЗУПе не открывается документ "начисление заработной платы.

Автор LenukaРаздел Пользователям "1С - Предприятие 8"

Ответов: 7
Просмотров: 5404
Последний ответ 14 Ноя 2014, 13:43
от pavl_vs
вставить "Справочники.'имя справочника из списка выбора'.СоздатьЭлемент()

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1076
Последний ответ 09 Окт 2017, 11:04
от Ivan94

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 486
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск