Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 05:47

Ошибка: "Метод объекта не обнаружен (сумма)" в пользовательском режиме

Автор jylik_88, 13 апр 2017, 18:53

0 Пользователей и 1 гость просматривают эту тему.

jylik_88

:( :dfbsdfbsdf:

1C 8.3 УТ 11.1

Подскажите, пожалуйста...
В пользовательском режиме выходит ошибка "Метод объекта не обнаружен (сумма)".
Я начинающий программист и не могу понять в чем ошибка :dfbsdfbsdf:

&НаСервере
Процедура ВыгрузитьПННаСервере()
   //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   СУММА(ПоступлениеТоваровУслугТовары.Количество) КАК Количество,
      |   СУММА(ПоступлениеТоваровУслугТовары.Сумма) КАК Сумма
      |ИЗ
      |   Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
      |ГДЕ
      |   ПоступлениеТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачалоПериода И &КонецПериода
      |   И ПоступлениеТоваровУслугТовары.Ссылка.Проведен";
   
   Запрос.УстановитьПараметр("КонецПериода", период.ДатаОкончания);
   Запрос.УстановитьПараметр("НачалоПериода", период.ДатаНачала);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            
История = Новый Массив;
Запись = Новый Структура;
Запись.Вставить("Количество", ВыборкаДетальныеЗаписи.количество);
Запись.Вставить("Сумма", ВыборкаДетальныеЗаписи.сумма);
История.Добавить(Запись);

КонецЦикла;


   //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

КонецПроцедуры

&НаКлиенте
Процедура ВыгрузитьПН(Команда)
   ВыгрузитьПННаСервере();
КонецПроцедуры

LexaK

в этом коде ошибок нет, посмотрите подробное описание ошибки, как правило там указывается модуль и номер строки кода где возникла ошибка и еще сама строка кода, вот эту строку и надо смотреть.
ответ Понравился? (в смысле пригодился?)

Igmok

Если речь идет о пользовательском режиме - проверьте, точно этот метод прописан в форме "в действиях".
Ошибка говорит о том, для действия не найдена функция, процедура или метод. Если я верно понял.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск