Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2021, 16:12

как связать реквизит (ДеревоЗначений) с данными дерева

Автор alex0402, 13 апр 2017, 17:43

0 Пользователей и 1 гость просматривают эту тему.

alex0402

На форме есть реквизит Значение типа (ДеревоЗначений)


&НаСервере
Процедура ОбновитьНаСервере(ИД)

  текДанные = Значение.НайтиПоИдентификатору(ИД);
  Дерево = РеквизитФормыВЗначение("Значение");
  //как определить какой именно строке дерева соответствуют текДанные?

КонецПроцедуры

&НаКлиенте
Процедура Обновить(Команда)

ОбновитьНаСервере(Элементы.Значение.ТекущиеДанные.ПолучитьИдентификатор());

КонецПроцедуры

Спасибо за Сказать спасибо

LexaK

я использую такую конструкцию при работе со строчками дерева
(когда-то давно написал, до сих пор работает)

пример кода


&НаКлиенте
Процедура ОбработатьТекстЗапросаКнопка(Команда)

НормализоватьТекстЗапроса(Элементы.ДеревоЗапросов.ТекущаяСтрока);

КонецПроцедуры

&НаСервере
Процедура НормализоватьТекстЗапроса(ИдентификаторТекущихДанных)

ТекущиеДанные = ДеревоЗапросов.НайтиПоИдентификатору(ИдентификаторТекущихДанных);
Если ТекущиеДанные = Неопределено Тогда
Возврат;
КонецЕсли;

ТекстЗапроса = ТекущиеДанные.ТекстЗапроса;
Если ПустаяСтрока(ТекстЗапроса) Тогда
Возврат;
КонецЕсли;

ОбработатьТекстЗапроса(ТекстЗапроса);
ТекущиеДанные.ТекстЗапроса = ТекстЗапроса;

//Параметры();
ЗаполнитьПараметрыЗапроса(ИдентификаторТекущихДанных) ;

КонецПроцедуры

ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск