Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 июн 2021, 01:19

Удаление Из ТЧ Документа по условию

Автор v7, 12 апр 2017, 11:59

0 Пользователей и 1 гость просматривают эту тему.

v7

Есть документ.У него есть табличная часть. Нужно удалять с нее товар по количеству, то есть не где Колво = Колво, а именно перебирать всю таблицу и если у нее есть в строке номенклатура с количеством, то нужно удалить столько, сколько было задано по условию. Если в строке кол-во меньше то программа идет дальше и дальше ищет строки и удаляет, до тех пор пока это кол-во не будет равняться условию. В моем коде нет этого условия.

   Отбор = Новый Структура();
   Отбор.Вставить("Номенклатура", ТекСтр.Номенклатура);
   Отбор.Вставить("Количество", ТекСтр.Надлежит);
   РезПоиска = РзДок.Товары.НайтиСтроки(Отбор);
   Пока стр.Количество < ТекСтр.Надлежит Ци
   Для каждого стр из РЗДок.Товары цикл
      
      РзДок.Товары.Удалить(Стр);
      
   КонецЦикла;
   РзДок.Записать(РежимЗаписиДокумента.Проведение);

alexandr_ll

Цитата: v7 от 12 апр 2017, 11:59
Есть документ.У него есть табличная часть. Нужно удалять с нее товар по количеству, то есть не где Колво = Колво, а именно перебирать всю таблицу и если у нее есть в строке номенклатура с количеством, то нужно удалить столько, сколько было задано по условию. Если в строке кол-во меньше то программа идет дальше и дальше ищет строки и удаляет, до тех пор пока это кол-во не будет равняться условию. В моем коде нет этого условия.

   Отбор = Новый Структура();
   Отбор.Вставить("Номенклатура", ТекСтр.Номенклатура);
   Отбор.Вставить("Количество", ТекСтр.Надлежит);
   РезПоиска = РзДок.Товары.НайтиСтроки(Отбор);
   Пока стр.Количество < ТекСтр.Надлежит Ци
   Для каждого стр из РЗДок.Товары цикл
      
      РзДок.Товары.Удалить(Стр);
      
   КонецЦикла;
   РзДок.Записать(РежимЗаписиДокумента.Проведение);
Что означает пятая строка кода?
Если нет условия, так поставьте его.
Для каждого стр из РЗДок.Товары цикл
Если стр.Количество < ТекСтр.Надлежит тогда
РзДок.Товары.Удалить(Стр);
КонецЕсли;
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск