Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 окт 2021, 23:29

Параметры Отбора в СКД из формы

Автор Rust, 06 апр 2017, 15:26

0 Пользователей и 1 гость просматривают эту тему.

Rust

Здравствуйте!
Есть форма с табличной частью,и отчет скд.
Как передать в Выборку имена из табличной части по кнопочке?

С параметрами получается,а с отбором мой "Франкенштейн" не работает.

temrmal

ничего не понятно: в какую выборку?

Rust

Цитата: temrmal от 07 апр 2017, 20:56
ничего не понятно: в какую выборку?
Отчет СКД,с ВЫБОРОКОЙ(Отбором)
Хочу передать через Компоновщик настроек
Добавлено: 12 апр 2017, 09:38


Работает с "Параметром" который предварительно есть в СКД.
Как сделать то же самое с "Отбором"? :dfbsdfbsdf:
Процедура ТЧБонусыДокторЛПУОткрытие(Отчет, СтандартнаяОбработка)
  ФормаОтчета = ПолучитьФорму("Отчет.t.Форма.ФормаОтчета");
   
    КомпоновщикНастроек = ФормаОтчета.Отчет.КомпоновщикНастроек;
    Настройки = КомпоновщикНастроек.Настройки;
    ЭлементНастройки = Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("par"));
    ЭлементНастройки.Значение = Объект.Комментарий;
    Если ЗначениеЗаполнено(ЭлементНастройки.ИдентификаторПользовательскойНастройки) Тогда
        ПользовательскийПараметр = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы.Найти(ЭлементНастройки.ИдентификаторПользовательскойНастройки);
        Если ТипЗнч(ПользовательскийПараметр) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") Тогда
            ПользовательскийПараметр.Значение = ЭлементНастройки.Значение;
        КонецЕсли;
    КонецЕсли;

    ФормаОтчета.Открыть();
    ФормаОтчета.СкомпоноватьРезультат();
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск