Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 23:51
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Параметры Отбора в СКД из формы  (Прочитано 710 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rust

  • *
  • Регистрация: 2017-03-09
  • Сообщений: 46
  • РЕПУТАЦИЯ: 0
Здравствуйте!
Есть форма с табличной частью,и отчет скд.
Как передать в Выборку имена из табличной части по кнопочке?

С параметрами получается,а с отбором мой "Франкенштейн" не работает.


Оффлайн temrmal

  • ***
  • Регистрация: 2011-11-10
  • Сообщений: 174
  • РЕПУТАЦИЯ: 22
  • КПД: 13%
ничего не понятно: в какую выборку?

Оффлайн Rust

  • *
  • Регистрация: 2017-03-09
  • Сообщений: 46
  • РЕПУТАЦИЯ: 0
ничего не понятно: в какую выборку?
Отчет СКД,с ВЫБОРОКОЙ(Отбором)
Хочу передать через Компоновщик настроек
Добавлено: 12 Апр 2017, 09:38

Работает с "Параметром" который предварительно есть в СКД.
Как сделать то же самое с "Отбором"? :dfbsdfbsdf:
Процедура ТЧБонусыДокторЛПУОткрытие(Отчет, СтандартнаяОбработка)
  ФормаОтчета = ПолучитьФорму("Отчет.t.Форма.ФормаОтчета");
   
    КомпоновщикНастроек = ФормаОтчета.Отчет.КомпоновщикНастроек;
    Настройки = КомпоновщикНастроек.Настройки;
    ЭлементНастройки = Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("par"));
    ЭлементНастройки.Значение = Объект.Комментарий;
    Если ЗначениеЗаполнено(ЭлементНастройки.ИдентификаторПользовательскойНастройки) Тогда
        ПользовательскийПараметр = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы.Найти(ЭлементНастройки.ИдентификаторПользовательскойНастройки);
        Если ТипЗнч(ПользовательскийПараметр) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") Тогда
            ПользовательскийПараметр.Значение = ЭлементНастройки.Значение;
        КонецЕсли;
    КонецЕсли;

    ФормаОтчета.Открыть();
    ФормаОтчета.СкомпоноватьРезультат();
КонецПроцедуры

Последний раз редактировалось: Rust; 12 Апр 2017, 09:38. Причина: Объединение сообщений


Теги:
 

Расшифровка поля отчета другим отчетом обычные формы.

Автор АнжелаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 931
Последний ответ 17 Июн 2020, 10:28
от Анжела
Как добавить фильтр в макет печатной формы?

Автор Otis FrostyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 188
Последний ответ 28 Сен 2020, 05:32
от alexandr_ll
удаление старой формы

Автор andrigРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 562
Последний ответ 24 Окт 2018, 08:51
от vitasw
Как скрыть\отобразить элементы формы меняя значение булево

Автор steeshiyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2983
Последний ответ 11 Мар 2019, 13:12
от steeshiy
Сохранять печатные формы сразу вместе с папками.

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1074
Последний ответ 01 Окт 2017, 18:50
от Farid Gasimli

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
23 Сообщений
alexandr_ll
15 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 207
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск