Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 05:58

Помогите с документом

Автор Анастасия Шумилина, 04 апр 2017, 13:34

0 Пользователей и 1 гость просматривают эту тему.

Анастасия Шумилина

1С:Предприятие 8.3 (8.3.5.1068)  БГУ 1.0.
Добрый день, подскажите такой вопрос. Делаю документ "Коммерция" в котором будут отображаться некоторые данные в таблице из справочника "Студенты".
В данном случае меня интересует реквизит "Плательщик" с формы элемента из справочника "Студенты".

Как записать в Процедуре?

ЦитироватьПроцедура ЗаполнитьСтрокуТабличнойЧасти(СтрокаТабличнойЧасти, СтрокаДанныхСтудентов)
СтрокаТабличнойЧасти.Студент = СтрокаДанныхСтудентов.Студент;
   
   СтрокаТабличнойЧасти.ПостоянныйНомер = СтрокаДанныхСтудентов.ПостоянныйНомер;
   СтрокаТабличнойЧасти.Группа = СтрокаДанныхСтудентов.Группа;
   СтрокаТабличнойЧасти.ДатаРождения = Формат(СтрокаДанныхСтудентов.ДатаРождения,"ДФ=yyyyMMdd");
   
   Фамилия = "";
   Имя = "";
   Отчество = "";
   ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(СтрокаДанныхСтудентов.ФИО, Фамилия, Имя, Отчество);
   СтрокаТабличнойЧасти.Фамилия = ВРег(Фамилия);
   СтрокаТабличнойЧасти.Имя = ВРег(Имя);
   СтрокаТабличнойЧасти.Отчество = ВРег(Отчество);
   СтрокаТабличнойЧасти.Учреждение = ВРег(Учреждение);
   СтрокаТабличнойЧасти.Плательщик = ЭлементыФормы.ТаблицаДоговоров.ТекущиеДанные.Плательщик;

   СтрокаТабличнойЧасти.СерияНомерПаспорта = СтрЗаменить(СтрокаДанныхСтудентов.СерияПаспорта, " ", "") + " " + СтрЗаменить(СтрокаДанныхСтудентов.НомерПаспорта, " ", "");
   СтрокаТабличнойЧасти.ДатаВыдачиПаспорта = Формат(СтрокаДанныхСтудентов.ДатаВыдачиПаспорта,"ДФ=yyyyMMdd");
   СтрокаТабличнойЧасти.КемВыданПаспорт = ВРег(СтрокаДанныхСтудентов.КемВыданПаспорт);

КонецПроцедуры









Rust

Цитата: Анастасия Шумилина от 04 апр 2017, 13:34
1С:Предприятие 8.3 (8.3.5.1068)  БГУ 1.0.
Добрый день, подскажите такой вопрос. Делаю документ "Коммерция" в котором будут отображаться некоторые данные в таблице из справочника "Студенты".
В данном случае меня интересует реквизит "Плательщик" с формы элемента из справочника "Студенты".

Как записать в Процедуре?

ЦитироватьПроцедура ЗаполнитьСтрокуТабличнойЧасти(СтрокаТабличнойЧасти, СтрокаДанныхСтудентов)
СтрокаТабличнойЧасти.Студент = СтрокаДанныхСтудентов.Студент;
   
   СтрокаТабличнойЧасти.ПостоянныйНомер = СтрокаДанныхСтудентов.ПостоянныйНомер;
   СтрокаТабличнойЧасти.Группа = СтрокаДанныхСтудентов.Группа;
   СтрокаТабличнойЧасти.ДатаРождения = Формат(СтрокаДанныхСтудентов.ДатаРождения,"ДФ=yyyyMMdd");
   
   Фамилия = "";
   Имя = "";
   Отчество = "";
   ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(СтрокаДанныхСтудентов.ФИО, Фамилия, Имя, Отчество);
   СтрокаТабличнойЧасти.Фамилия = ВРег(Фамилия);
   СтрокаТабличнойЧасти.Имя = ВРег(Имя);
   СтрокаТабличнойЧасти.Отчество = ВРег(Отчество);
   СтрокаТабличнойЧасти.Учреждение = ВРег(Учреждение);
   СтрокаТабличнойЧасти.Плательщик = ЭлементыФормы.ТаблицаДоговоров.ТекущиеДанные.Плательщик;

   СтрокаТабличнойЧасти.СерияНомерПаспорта = СтрЗаменить(СтрокаДанныхСтудентов.СерияПаспорта, " ", "") + " " + СтрЗаменить(СтрокаДанныхСтудентов.НомерПаспорта, " ", "");
   СтрокаТабличнойЧасти.ДатаВыдачиПаспорта = Формат(СтрокаДанныхСтудентов.ДатаВыдачиПаспорта,"ДФ=yyyyMMdd");
   СтрокаТабличнойЧасти.КемВыданПаспорт = ВРег(СтрокаДанныхСтудентов.КемВыданПаспорт);

КонецПроцедуры







Процедура ПриИзмененииСтудент()
Объект.Плательщик(На форме)=Объект.Студент.Плательщик;
КонецПроцедуры

Как то в этом направлении

Анастасия Шумилина

Пишет что не хватает знака ")"    :(:(:(:(
Процедура ПриИзмененииСтудент()
Объект.Плательщик(На форме)=Объект.Студент.Плательщик;
КонецПроцедуры

Как то в этом направлении
[/quote]

Rust

Цитата: Анастасия Шумилина от 04 апр 2017, 14:31
Пишет что не хватает знака ")"    :(:(:(:(
Это просто для примера.
К сожалению,только этим могу помочь.

Анастасия Шумилина

аааа, ну хорошо попробую покумекать, спасибо за ответ )

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск