Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 17:26
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Помогите с документом  (Прочитано 1319 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анастасия Шумилина

  • *
  • Регистрация: 2017-04-04
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
1С:Предприятие 8.3 (8.3.5.1068)  БГУ 1.0.
 Добрый день, подскажите такой вопрос. Делаю документ "Коммерция" в котором будут отображаться некоторые данные в таблице из справочника "Студенты".
В данном случае меня интересует реквизит "Плательщик" с формы элемента из справочника "Студенты".

Как записать в Процедуре?

Цитировать
Процедура ЗаполнитьСтрокуТабличнойЧасти(СтрокаТабличнойЧасти, СтрокаДанныхСтудентов)
СтрокаТабличнойЧасти.Студент = СтрокаДанныхСтудентов.Студент;
   
   СтрокаТабличнойЧасти.ПостоянныйНомер = СтрокаДанныхСтудентов.ПостоянныйНомер;
   СтрокаТабличнойЧасти.Группа = СтрокаДанныхСтудентов.Группа;
   СтрокаТабличнойЧасти.ДатаРождения = Формат(СтрокаДанныхСтудентов.ДатаРождения,"ДФ=yyyyMMdd");
   
   Фамилия = "";
   Имя = "";
   Отчество = "";
   ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(СтрокаДанныхСтудентов.ФИО, Фамилия, Имя, Отчество);
   СтрокаТабличнойЧасти.Фамилия = ВРег(Фамилия);
   СтрокаТабличнойЧасти.Имя = ВРег(Имя);
   СтрокаТабличнойЧасти.Отчество = ВРег(Отчество);
   СтрокаТабличнойЧасти.Учреждение = ВРег(Учреждение);
   СтрокаТабличнойЧасти.Плательщик = ЭлементыФормы.ТаблицаДоговоров.ТекущиеДанные.Плательщик;

   СтрокаТабличнойЧасти.СерияНомерПаспорта = СтрЗаменить(СтрокаДанныхСтудентов.СерияПаспорта, " ", "") + " " + СтрЗаменить(СтрокаДанныхСтудентов.НомерПаспорта, " ", "");
   СтрокаТабличнойЧасти.ДатаВыдачиПаспорта = Формат(СтрокаДанныхСтудентов.ДатаВыдачиПаспорта,"ДФ=yyyyMMdd");
   СтрокаТабличнойЧасти.КемВыданПаспорт = ВРег(СтрокаДанныхСтудентов.КемВыданПаспорт);

КонецПроцедуры










Оффлайн Rust

  • *
  • Регистрация: 2017-03-09
  • Сообщений: 46
  • РЕПУТАЦИЯ: 0
1С:Предприятие 8.3 (8.3.5.1068)  БГУ 1.0.
 Добрый день, подскажите такой вопрос. Делаю документ "Коммерция" в котором будут отображаться некоторые данные в таблице из справочника "Студенты".
В данном случае меня интересует реквизит "Плательщик" с формы элемента из справочника "Студенты".

Как записать в Процедуре?

Цитировать
Процедура ЗаполнитьСтрокуТабличнойЧасти(СтрокаТабличнойЧасти, СтрокаДанныхСтудентов)
СтрокаТабличнойЧасти.Студент = СтрокаДанныхСтудентов.Студент;
   
   СтрокаТабличнойЧасти.ПостоянныйНомер = СтрокаДанныхСтудентов.ПостоянныйНомер;
   СтрокаТабличнойЧасти.Группа = СтрокаДанныхСтудентов.Группа;
   СтрокаТабличнойЧасти.ДатаРождения = Формат(СтрокаДанныхСтудентов.ДатаРождения,"ДФ=yyyyMMdd");
   
   Фамилия = "";
   Имя = "";
   Отчество = "";
   ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(СтрокаДанныхСтудентов.ФИО, Фамилия, Имя, Отчество);
   СтрокаТабличнойЧасти.Фамилия = ВРег(Фамилия);
   СтрокаТабличнойЧасти.Имя = ВРег(Имя);
   СтрокаТабличнойЧасти.Отчество = ВРег(Отчество);
   СтрокаТабличнойЧасти.Учреждение = ВРег(Учреждение);
   СтрокаТабличнойЧасти.Плательщик = ЭлементыФормы.ТаблицаДоговоров.ТекущиеДанные.Плательщик;

   СтрокаТабличнойЧасти.СерияНомерПаспорта = СтрЗаменить(СтрокаДанныхСтудентов.СерияПаспорта, " ", "") + " " + СтрЗаменить(СтрокаДанныхСтудентов.НомерПаспорта, " ", "");
   СтрокаТабличнойЧасти.ДатаВыдачиПаспорта = Формат(СтрокаДанныхСтудентов.ДатаВыдачиПаспорта,"ДФ=yyyyMMdd");
   СтрокаТабличнойЧасти.КемВыданПаспорт = ВРег(СтрокаДанныхСтудентов.КемВыданПаспорт);

КонецПроцедуры







Процедура ПриИзмененииСтудент()
Объект.Плательщик(На форме)=Объект.Студент.Плательщик;
КонецПроцедуры
Как то в этом направлении

Оффлайн Анастасия Шумилина

  • *
  • Регистрация: 2017-04-04
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
Пишет что не хватает знака ")"    :(:(:(:(
Процедура ПриИзмененииСтудент()
Объект.Плательщик(На форме)=Объект.Студент.Плательщик;
КонецПроцедуры
Как то в этом направлении
[/quote]

Оффлайн Rust

  • *
  • Регистрация: 2017-03-09
  • Сообщений: 46
  • РЕПУТАЦИЯ: 0
Пишет что не хватает знака ")"    :(:(:(:(
Это просто для примера.
К сожалению,только этим могу помочь.

Оффлайн Анастасия Шумилина

  • *
  • Регистрация: 2017-04-04
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
аааа, ну хорошо попробую покумекать, спасибо за ответ )


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 454
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск