Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 12:45

Заполнение таблицы из регистра сведений

Автор MUIIIKA, 04 апр 2017, 12:34

0 Пользователей и 1 гость просматривают эту тему.

MUIIIKA

Добрый день! Ребят подскажите пожалуйста как реализовать. Есть табличная часть в которой указана дата платежа и месяц платежа по договору, информацию беру из непериодического регистра сведений, Там также дата и месяц есть. задача следующая как заполнять в табличной части поля при проведении документа оплата(записывает в регистр, может не нужно тянуть из регистра??) по типу дата платежа + 1 месяц оплаты, создаем 1 строку с датой платежа и цифрой 1 в 1-ой колонке, далее следующий месяц например дата платежа 3 месяца, тогда создаем три строки заполняем датой и 3 столбца цифрой 3 или например сразу 8 месяцев надо 8 строк + добавить 8-ки в 8 стобцов.

Пока могу добавить 1 строку + 1 месяц, но опять же нужно проверять был ли уже платеж по этому договору, тоесть все таки регистр нужно использовать?


&НаСервере
Процедура ОплатаДоговораНаСервере()
            Объект.ГрафикПлатежей.Очистить();
      Запрос = Новый Запрос;     
      Запрос.Текст =       "ВЫБРАТЬ
      |      УчетОплаты.ДатаОплаты,     
        |      УчетОплаты.МесяцОплаты
      |ИЗ
      |      РегистрСведений.УчетОплаты КАК УчетОплаты
      |ГДЕ
      |      УчетОплаты.Договор.Ссылка = &ДСсылка";
      Запрос.УстановитьПараметр("ДСсылка", Объект.Ссылка);
      Выб = Запрос.Выполнить().Выбрать();
      Пока Выб.Следующий() Цикл
            НС = Объект.ГрафикПлатежей.Добавить();
            НС.ДатаОплаты = Выб.ДатаОплаты;
                   Если Выб.МесяцОплаты = 1 Тогда
                    НС.Месяц1 = Выб.МесяцОплаты;
                     КонецЕсли;
      КонецЦикла;
КонецПроцедуры

temrmal

Ничего не понятно! Что за документ оплата? Где эта табличная часть? В каком документе?

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск