Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 09:54
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Заполнение таблицы из регистра сведений  (Прочитано 1036 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MUIIIKA

  • *
  • Регистрация: 2011-10-01
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Добрый день! Ребят подскажите пожалуйста как реализовать. Есть табличная часть в которой указана дата платежа и месяц платежа по договору, информацию беру из непериодического регистра сведений, Там также дата и месяц есть. задача следующая как заполнять в табличной части поля при проведении документа оплата(записывает в регистр, может не нужно тянуть из регистра??) по типу дата платежа + 1 месяц оплаты, создаем 1 строку с датой платежа и цифрой 1 в 1-ой колонке, далее следующий месяц например дата платежа 3 месяца, тогда создаем три строки заполняем датой и 3 столбца цифрой 3 или например сразу 8 месяцев надо 8 строк + добавить 8-ки в 8 стобцов.
 
Пока могу добавить 1 строку + 1 месяц, но опять же нужно проверять был ли уже платеж по этому договору, тоесть все таки регистр нужно использовать?
 
 
&НаСервере
Процедура ОплатаДоговораНаСервере()
            Объект.ГрафикПлатежей.Очистить();
      Запрос = Новый Запрос;     
      Запрос.Текст =       "ВЫБРАТЬ
      |      УчетОплаты.ДатаОплаты,     
        |      УчетОплаты.МесяцОплаты
      |ИЗ
      |      РегистрСведений.УчетОплаты КАК УчетОплаты
      |ГДЕ
      |      УчетОплаты.Договор.Ссылка = &ДСсылка";
      Запрос.УстановитьПараметр("ДСсылка", Объект.Ссылка);
      Выб = Запрос.Выполнить().Выбрать();
      Пока Выб.Следующий() Цикл
            НС = Объект.ГрафикПлатежей.Добавить();
            НС.ДатаОплаты = Выб.ДатаОплаты;
                   Если Выб.МесяцОплаты = 1 Тогда
                    НС.Месяц1 = Выб.МесяцОплаты;
                     КонецЕсли;
      КонецЦикла;
КонецПроцедуры


Оффлайн temrmal

  • ***
  • Регистрация: 2011-11-10
  • Сообщений: 174
  • РЕПУТАЦИЯ: 22
  • КПД: 13%
Ничего не понятно! Что за документ оплата? Где эта табличная часть? В каком документе?


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
22 Сообщений
alexandr_ll
15 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск