Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 05:44

Документы

Автор AB, 03 апр 2017, 10:04

0 Пользователей и 1 гость просматривают эту тему.

AB

Добрый день!

Вот тут мне посоветовали

Вроде все понятно, но так и не получилось.

Создал перечисления:
Магазин1
Маназин2

Создал Регистр Сведений:
Измерения - Магазин (справочник.Магазин)
Ресурсы - Действие (Перечисления.Перечисления1)

Заполнил регистр:
Магазин Дикси - Действие1

Магазин Перекресток - Действие2


Потом такой код:


ВидКода = РегистрыСведений.аааааПоискМагазина.Получить(Новый Структура("Магазин",Объект.ДокументОснование.Магазин)) ;
Если  ВидКода =  "Магазин Дикси" тогда
ВызватьИсключение "Работает!";
Иначе
ВызватьИсключение "Не работает!";
КонецЕсли;


Или так(точно не понимаю что в условие передать)

Если  ВидКода = "Действие1" тогда

Но как итог не работает(ни 1 ни второе). Ну так не работает, только условие иначе.

Kironten

Структура = РегистрыСведений.аааааПоискМагазина.Получить(ТекущаяДата() ,Новый Структура("Магазин",Объект.ДокументОснование.Магазин)) ;

    Если  Структура.Действие = Перечисления.Перечисление1.Действие1 тогда
        ВызватьИсключение "Работает!";
    Иначе
        ВызватьИсключение "Не работает!";
    КонецЕсли;

ilyay

Читайте справку по методу Получить() для "РегистрыСведенийМенеджер.<Имя регистра сведений>". Какие параметры передаются и какой тип результата у возвращаемого значения.

alex0402

Цитата: AB от 03 апр 2017, 10:04Создал перечисления:
Магазин1
Маназин2
Нужно
Действие1
Действие2

Структура = РегистрыСведений.аааааПоискМагазина.Получить(ТекущаяДата() ,Новый Структура("Магазин",Объект.ДокументОснование.Магазин)) ;
//регистр периодический? если нет, то

Структура = РегистрыСведений.аааааПоискМагазина.Получить(Новый Структура("Магазин",Объект.ДокументОснование.Магазин)) ;

    Если  Структура.Действие = Перечисления.Перечисление1.Действие1 тогда
        ВызватьИсключение "Работает!";
    Иначе
        ВызватьИсключение "Не работает!";
    КонецЕсли;

Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск