Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 11:45

Изменение элементов справочника Физические Лица ЗУП 2.5

Автор ksander-fars, 03 апр 2017, 08:31

0 Пользователей и 1 гость просматривают эту тему.

ksander-fars

Здравствуйте. Подскажите пожалуйста по такому вопросу. После обновления около года назад в справочнике "Физические лица" на вкладке "Персональные данные" в таблице "Учеба" сменились виды образования. У сотрудников имевших "Вид образования" "Высшее профессиональное образование" вид изменилcя на "Высшее образование - специалитет, магистратура". Подскажите как обойти весь справочник и у всех у кого вид образования "Высшее образование - специалитет, магистратура" заменить на "Высшее профессиональное образование"?

alex0402

Выборка = Справочники.ФизическиеЛиц.Выбрать();
Пока Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    //сделать что-то
    Объект.Записать();
КонецЦикла;
Спасибо за Сказать спасибо

ksander-fars

Да это как раз понятно что в цикле обходим справочник и записываем результат. Я не могу понять как обойти табличную часть Образование, каким методом получить информацию из неё, метод выгрузить колонки не подходит так как выгружает пустые колонки...

Kironten

Цитата: ksander-fars от 03 апр 2017, 10:03Я не могу понять как обойти табличную часть Образование,

Циклом

ls600

Табличную часть обходи циклом
Для  Каждого Строки Из ВашаТабличнаяЧасть Цикл
*****
тут делаешь что тебе нужно и записываешь
КонецЦикла

alex0402

Выборка = Справочники.ФизическиеЛиц.Выбрать();
Пока Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    Для каждого Образование из Объект.Образование
        Если Образование.Образование = "это" Тогда
             //сделать то
        КонецЕсли;
    КонецЦикла
    Объект.Записать();
КонецЦикла;
Спасибо за Сказать спасибо

ksander-fars


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск