Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 08:48
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Изменение элементов справочника Физические Лица ЗУП 2.5  (Прочитано 1672 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ksander-fars

  • **
  • Регистрация: 2016-05-04
  • Сообщений: 78
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Профессия: Ученик 1С
Здравствуйте. Подскажите пожалуйста по такому вопросу. После обновления около года назад в справочнике "Физические лица" на вкладке "Персональные данные" в таблице "Учеба" сменились виды образования. У сотрудников имевших "Вид образования" "Высшее профессиональное образование" вид изменилcя на "Высшее образование - специалитет, магистратура". Подскажите как обойти весь справочник и у всех у кого вид образования "Высшее образование - специалитет, магистратура" заменить на "Высшее профессиональное образование"?


Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
Выборка = Справочники.ФизическиеЛиц.Выбрать();
Пока Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    //сделать что-то
    Объект.Записать();
КонецЦикла;
Спасибо за Сказать спасибо

Оффлайн ksander-fars

  • **
  • Регистрация: 2016-05-04
  • Сообщений: 78
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Профессия: Ученик 1С
Да это как раз понятно что в цикле обходим справочник и записываем результат. Я не могу понять как обойти табличную часть Образование, каким методом получить информацию из неё, метод выгрузить колонки не подходит так как выгружает пустые колонки...

Оффлайн Kironten

  • *****
  • Регистрация: 2013-08-12
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Профессия: Ученик 1С
Я не могу понять как обойти табличную часть Образование,

Циклом

Оффлайн ls600

  • ****
  • Регистрация: 2012-05-14
  • Сообщений: 371
  • РЕПУТАЦИЯ: 30
  • КПД: 8%
  • Профессия: Программист 1С
Табличную часть обходи циклом
Для  Каждого Строки Из ВашаТабличнаяЧасть Цикл
*****
тут делаешь что тебе нужно и записываешь
КонецЦикла

Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
Выборка = Справочники.ФизическиеЛиц.Выбрать();
Пока Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    Для каждого Образование из Объект.Образование
        Если Образование.Образование = "это" Тогда
             //сделать то
        КонецЕсли;
    КонецЦикла
    Объект.Записать();
КонецЦикла;
Спасибо за Сказать спасибо

Оффлайн ksander-fars

  • **
  • Регистрация: 2016-05-04
  • Сообщений: 78
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Профессия: Ученик 1С
Спасибо большое за помощь.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
22 Сообщений
SSC
15 Сообщений
alexandr_ll
15 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 189
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск