Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 сен 2021, 17:42

Доработка отчета "продажи"

Автор vikras, 31 мар 2017, 21:53

0 Пользователей и 1 гость просматривают эту тему.

vikras

Как правильно добавить в отчет Цену прихода из приходной накладной?
Пробовал вписать в запрос:
|Цена0 = Документ.ПриходнаяНакладная.Цена0;
Но после формирования отчета,цена прихода у каждого товара равна нулю.



Процедура Очистить()
  ВыбТовар=0;
КонецПроцедуры

Процедура Сформировать()

Перем Запрос,Флаг;
Ном=0;
ИтогСумма=0;
Запрос=СоздатьОбъект("Запрос");

    Флаг = Запрос.Выполнить("
    |Период с ДатаНач по ДатаКон;
|Товар = Документ.РасходнаяНакладная.Товар;
|Количество = Документ.РасходнаяНакладная.Колич;
|Сумма = Документ.РасходнаяНакладная.Сумма;
    |Фирма = Документ.РасходнаяНакладная.Фирма;
|Группировка Товар упорядочить по Товар.Наименование;
|Условие (Фирма=ВыбФ);
|Функция ИтСум=Расход(Сумма);
|Функция ИтКол=Расход(Количество);
|");
    Если Флаг = 0 Тогда
Возврат;
КонецЕсли;
Таб=СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Отчет");
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.ИтКол <>0 Тогда
ИтогСумма=ИтогСумма+Запрос.ИтСум;
Ном=Ном+1;
СрЦена=Формат(Запрос.ИтСум/Запрос.ИтКол,"Ч17.2");
Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЦикла;
Таб.ВывестиСекцию("Подвал");
Таб.Опции(0,0,0,0);
Таб.Показать("","");

КонецПроцедуры

Процедура ПриОткрытии()
    ДатаНач=ДобавитьМесяц(ТекущаяДата(),-1);
    ДатаКон=ТекущаяДата();
КонецПроцедуры


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск