Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2021, 21:13

Ошибка в настройке упр. учета

Автор Abdiev Aibek, 31 мар 2017, 15:45

0 Пользователей и 1 гость просматривают эту тему.

Abdiev Aibek

Добрый день! Проблема в общем следующая... Купили базу у коллег (подходит по возможностям) Начали настраивать под себя, пытались создать учетную политику все заполняем, жмем ОК и тут выходит ошибка (фото)


Содержимое из конфигуратора:

Процедура ПередЗаписьюРегистраДатаЗапретаРедактированияПередЗаписью(Источник, Отказ, Замещение) Экспорт

Если ТипЗнч(Источник.Отбор.Регистратор.Значение) = Тип("ДокументСсылка.ЗаказПокупателя")
или ТипЗнч(Источник.Отбор.Регистратор.Значение) = Тип("ДокументСсылка.ЗаказПоставщику")
ИЛИ ТипЗнч(Источник.Отбор.Регистратор.Значение) = Тип("ДокументСсылка.ПеремещениеТоваров") тогда
ВОзврат;
КонецЕсли;

ПроверкаПериодаЗаписейРегистров(Источник, Отказ);
Если Отказ Тогда
#Если Клиент Тогда
Сообщить("Редактирование данных этого периода запрещено. Изменения не могут быть записаны...", СтатусСообщения.Важное);
#КонецЕсли
КонецЕсли;

КонецПроцедуры // ПередЗаписьюРегистраДатаЗапретаРедактированияПередЗаписью()

ilyay

Картинки нет. С вопросом разумно обратиться туда, куда платили деньги. #Если Клиент относится к коду, выполняемому в режиме толстого клиента.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск