Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 06:52

Печать документа из ВнешнейОбработки

Автор z3x, 28 мар 2017, 15:09

0 Пользователей и 1 гость просматривают эту тему.

z3x

Здравствуйте!
Задача: Запускаем внешнюю обработку (открывается форма). На форме есть некие поля (реквизиты) и  кнопка "печать".
При нажатии открывается Табличный документ для печати.

Все роде как работает, но Табличный документ открывается ущербный. Нет кнопок Печать, Сохранить, ...

Вот что у меня есть

&НаКлиенте
Процедура ПечатьСтиекров(Команда)
тб = ПречатьСтикеровНаСервере();
тб.Показать();   
КонецПроцедуры

&НаСервере
Функция ПречатьСтикеровНаСервере()

ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент.ПолеСверху = 5;
ТабличныйДокумент.ИмяПараметровПечати ="ПАРАМЕТРЫ_ПЕЧАТИ_Стикеры_Печать";

эт = РеквизитФормыВЗначение("Объект");
Макет  = эт.ПолучитьМакет("Макет");


СтикерОбласть = Макет.ПолучитьОбласть("Стикер");

Для НомерНаклейки=1 По КоличествоКоробов Цикл

СтикерОбласть.Параметры.Контр=Контр;
СтикерОбласть.Параметры.НомерНаклейки=НомерНаклейки;
СтикерОбласть.Параметры.всего=КоличествоКоробов;

ТабличныйДокумент.Вывести(СтикерОбласть);
    ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();

КонецЦикла;


Возврат ТабличныйДокумент;
КонецФункции


Как сделать что бы была кнопка печать, сохранить,... ???
Спасибо.
1С:Предприятие 8.3 (8.3.9.2233)

LexaK

так это в основном меню есть
Основное меню - Файл - Сохранить как
там же и Печать!

(права только проверьте)
или используйте стандартный функционал (из БСП 2.0 - общая форма Печати)
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск