Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 сен 2021, 02:17

не срабатывает условие на добавление строки в табличную часть при открытии формы

Автор MUIIIKA, 28 мар 2017, 12:11

0 Пользователей и 1 гость просматривают эту тему.

MUIIIKA

&НаКлиенте
Процедура ПриОткрытии(Отказ)

Стр = Элементы.Услуги.ТекущиеДанные;     
   Если Стр = Неопределено Тогда
   Стр = Объект.Услуги.Добавить();
   Стр.Количество = 1;
    Объект.ДатаДоговора = ТекущаяДата();
    КонецЕсли;
КонецПроцедуры

MUIIIKA

Если кому-то интересно, решение такое, спасибо!
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ТЧ = Объект.Услуги;
Если ТЧ.Количество() = 0 Тогда
  Стр = ТЧ.Добавить();
  Стр.Количество = 1;
  Объект.ДатаДоговора = ТекущаяДата();
КонецЕсли;
КонецПроцедуры

Теги: 1С 8.2 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск