Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 06:05

Предыдущая Дата в печатной форме

Автор Mexxe, 26 мар 2017, 09:22

0 Пользователей и 1 гость просматривают эту тему.

Mexxe

Добрый день профессионалы!
Помогите пожалуйста разобраться с предыдущей датой, как возможно это реализовать?
Задача стоит такая, в печатной форма Заявления нужно вместо текущей даты, нужна дата 3-х дневной давности, это реализовано таким образом
Функция ДатаЗаявления()
Сегодня = ТекущаяДата ();
ПредыдущаяДата = Сегодня - 72 * 60 * 60;
Если ПредыдущаяДата = ДеньНедели
Возврат (ПредыдущаяДата);
КонецФункции
Но теперь стоит новая задача, как реализовать что бы "предыдущая" дата не выпадала на выходной день (только суб и воскр), т.е. если дата выпадает на эти выходные то дата была предыдущей пятницы.
За ранее благодарен!

alex0402

Функция ДатаЗаявления()
Сегодня = ТекущаяДата ();
ПредыдущаяДата = Сегодня - 259200;
Пока ДеньНедели(ПредыдущаяДата) = 0 или ДеньНедели(ПредыдущаяДата) = 0 Цикл
    ПредыдущаяДата = ПредыдущаяДата - 86400;
КонецЦикла;
Возврат (ПредыдущаяДата);
КонецФункции


Спасибо за Сказать спасибо

Mexxe

Цитата: alex0402 от 26 мар 2017, 10:47
Функция ДатаЗаявления()
Сегодня = ТекущаяДата ();
ПредыдущаяДата = Сегодня - 259200;
Пока ДеньНедели(ПредыдущаяДата) = 0 или ДеньНедели(ПредыдущаяДата) = 0 Цикл
    ПредыдущаяДата = ПредыдущаяДата - 86400;
КонецЦикла;
Возврат (ПредыдущаяДата);
КонецФункции

Спасибо, вроде все работает!
Только вместо нулей нужно поставить 6 и 7 правильно?

alex0402

Спасибо за Сказать спасибо

Mexxe

Цитата: alex0402 от 26 мар 2017, 11:42
Скорее 0 и 6. проверь .
А почему 0 и 6?
6 и 7 поставил, вроде все правильно.
Спасибо! 

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск