Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 07:27

Надоела надпись "Вы действительно хотите выйти из программы"

Автор FaceControl, 25 мар 2017, 08:29

0 Пользователей и 1 гость просматривают эту тему.

FaceControl

Платформа 7.7 (7.70.027)
Конфигурация Бухгалтерия

Windows 8.1 Pro x64
Windows 7 Max x32

Пожалуйста помогите мне решить проблему, весь инет облазил не нашол, вот решил создать тему сдесь.

Проблема:
При работе в программе 1С Предприятие 7.7, каждую минуту самостаятельно выходит табличка с вопросом как при нажатии выход "Вы действительно хотите выйти из программы ?". Очень мешает работать, помогите исправить ошибку.

Вот нашол запись в глобальном модуле предидущего программиста:

Процедура ПриЗавершенииРаботыСистемы()
   //Если Константа.ЗапрашиватьПриЗакрытии=Перечисление.Булево.Да Тогда 
   Если йцкй223333нне777=ногегоег9990088 Тогда
      Если Вопрос("Вы действительно хотите выйти из программы ?",4)=6 Тогда
         УдалениеМХЛФайлов();
      Иначе
         СтатусВозврата(0);
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры   //ПриЗавершенииРаботыСистемы


Что мне исправить, что добавить?

ЗАРАНЕЕ ОЧЕНЬ БЛАГОДАРЮ!!!

alexandr_ll

У вас изменена конфигурация по сравнению с типовой, по крайней мере глобальный модуль.
Если хотите отменить появление вопроса, то закомментируйте все строки процедуры, кроме удаленимхл(), кстати, а что делает эта процедура?

alex0402

Нужно искать обработку ожидания. Подключается процедурой ОбработкаОжидания(<?>,)
Спасибо за Сказать спасибо

FaceControl

Цитата: alexandr_ll от 26 мар 2017, 09:31
У вас изменена конфигурация по сравнению с типовой, по крайней мере глобальный модуль.
Если хотите отменить появление вопроса, то закомментируйте все строки процедуры, кроме удаленимхл(), кстати, а что делает эта процедура?

Ведь если я закомментирую эти строки, то выход из программы будет не возможен, ведь так?

Процедуру удалениемхл() я не писал это делал предыдущий программист

Так что мне делать???
Добавлено: 01 апр 2017, 14:02


Цитата: alex0402 от 26 мар 2017, 10:39
Нужно искать обработку ожидания. Подключается процедурой ОбработкаОжидания(<?>,)

Нашел вот это:
СписокОкон=СоздатьОбъект("СписокЗначений"); //см. (Процедура глОткрыватьОкноПриСтарте)
ОбработкаОжидания("ЗаполнениеТаб",35);

Добавлено: 01 апр 2017, 14:02


Что мне делать помогите???

alex0402

Цитата: FaceControl от 01 апр 2017, 13:59ОбработкаОжидания("ЗаполнениеТаб",35);

что в процедуре ЗаполнениеТаб? Должна быть в глобальном модуле?

Похоже с программистом не очень хорошо расстались!
Спасибо за Сказать спасибо

Рейтинг@Mail.ru Rambler's Top100

Поиск