Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 окт 2021, 23:49

Изменить текст запроса динамического списка

Автор gvm1969, 22 мар 2017, 14:03

0 Пользователей и 1 гость просматривают эту тему.

gvm1969

1С:Предприятие 8.3 (8.3.9.1818)
Возникла следующая проблема:
В управляемой форме необходимо при определенных условиях изменить текст запроса динамического списка.
Я это сделал так:

&НаКлиенте
Процедура ОтборПоСтатусамПриИзменении(Элемент)
        .................................   
   ..................................
   СменитьЗапрос(Список, стрЗапроса);
                   
   ЭтаФорма.ОбновитьОтображениеДанных();
   Элементы.Список.Обновить();   
   
КонецПроцедуры

&НаСервере
Процедура СменитьЗапрос(ДС, СтрокаЗапроса)

   ДС.ТекстЗапроса = СтрокаЗапроса;
   Элементы.Список.Обновить();                   
КонецПроцедуры

В отладчике я вижу новый текст запроса.
А в форме ничего не меняется.

Метод Обновить() пробовал и только на сервере, и только на клиенте, и на сервере а затем на клиенте.
Что я делаю не так?

has

Попробовал, меняет

&НаСервере
Процедура ИзенитьЗапросНаСервере()
ДС.ТекстЗапроса =
"ВЫБРАТЬ
| ХП_Должности.Наименование
|ИЗ
| Справочник.ХП_Должности КАК ХП_Должности";
Элементы.ДС.Обновить();
КонецПроцедуры

&НаКлиенте
Процедура ИзенитьЗапрос(Команда)
ИзенитьЗапросНаСервере();
КонецПроцедуры


Попробуй закоментировать код

ЭтаФорма.ОбновитьОтображениеДанных();
Элементы.Список.Обновить();

alex0402

Цитата: gvm1969 от 22 мар 2017, 14:03В управляемой форме необходимо при определенных условиях изменить текст запроса динамического списка.

а не проще использовать запрос:
ВЫБРАТЬ Поле1,Поле2 ИЗ Таблица Где Условие
ОБЪЕДИНИТЬ ВСЕ
ВЫБРАТЬ Поле1,Поле2 ИЗ Таблица Где Не Условие


и ничего динамически менять не надо!
Спасибо за Сказать спасибо

gvm1969


has

Попробуй просто в во внешней обработке изменить. Элемент формы связан со списком?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск