Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Июн 2021, 17:08
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Стандартная обработка = Ложь, как добавлять тот или иной элемент.  (Прочитано 3103 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Igor100500

  • **
  • Регистрация: 2015-11-20
  • Сообщений: 51
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Здравствуйте, как добавлять при выборе из справочника в табличную часть что - либо?
Вот есть документ, выбираем номенклатуру колбаса, в табличной части товары выбираем единицу измерения(установил отбор).
Открываю форму

ФормаВыб = Справочники.ЕдиницыИзмерения.ПолучитьФорму("ФормаВыбора", ЭтаФорма);
ФормаВыб.Отбор.Владелец.Значение = объект.Номенклатура;
ФормаВыб.Отбор.Владелец.Использование = Истина;
ФормаВыб.РежимВыбора = Истина;
ФормаВыб.Открыть();

потом при изменении единицы измерения
        СтандартнаяОбработка=Ложь;	
ПолучателиЕдиницаИзмеренияПриИзмененииНаСервере();

Все открывает как надо, но он не подставляет в табличную часть то значение которое я выбрал(допустим штуки)
подсмотрел на форумах, нужно чтото такое дописать
&НаКлиенте
Процедура ПолучателиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)

СтандартнаяОбработка=Ложь;

НоваяСтрока = Элементы.Получатели.ДобавитьСтроку();

НоваяСтрока.ЕдиницаИзмерения = ВыбранноеЗначение;

КонецПроцедуры
и не пашет, что не так?


Оффлайн Dethmontt

  • Денис
  • *****
  • Регистрация: 2010-11-01
  • Сообщений: 2892
  • РЕПУТАЦИЯ: 552
  • КПД: 19%
  • Адын Эс
  • Профессия: Программист 1С
ФормаВыб = Справочники.ЕдиницыИзмерения.ПолучитьФорму("ФормаВыбора", ЭтаФорма);

ФормаВыб = Справочники.ЕдиницыИзмерения.ПолучитьФорму("ФормаВыбора", Элемент);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Igor100500

  • **
  • Регистрация: 2015-11-20
  • Сообщений: 51
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
ФормаВыб = Справочники.ЕдиницыИзмерения.ПолучитьФорму("ФормаВыбора", ЭтаФорма);

ФормаВыб = Справочники.ЕдиницыИзмерения.ПолучитьФорму("ФормаВыбора", Элемент);
Нет, он получит значения ТЧ, а ЭтаФорма получает вообще все. Так что разницы не будет.
Ну и уже разрешили все.
&НаСервере
&НаСервере
функция ПолучателиЕдиницаИзмеренияПриИзмененииНаСервере()
    ФормаВыб = Справочники.ЕдиницыИзмерения.ПолучитьФорму("ФормаВыбора",ЭтаФорма);
ФормаВыб.Отбор.Владелец.Значение = объект.Номенклатура;
ФормаВыб.Отбор.Владелец.Использование = Истина;
ФормаВыб.РежимВыбора = Истина;

ФормаВыб.ОткрытьМодально();
ном = ФормаВыб.ТекущийЭлемент.ТекущиеДанные;
возврат ном.ссылка;
Конецфункции

&НаКлиенте
Процедура ПолучателиЕдиницаИзмеренияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка=Ложь;
    СтрТЧ = Элементы.Получатели.ТекущиеДанные;
    Элементы.Получатели.ДобавитьСтроку();
   
    ВыбранноеЗначение = ПолучателиЕдиницаИзмеренияПриИзмененииНаСервере();
       
    ПолучателиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка);
   
    ВыбранноеЗначение = объект.ЕдиницаИзмерения;
   
   
КонецПроцедуры

&НаКлиенте
Процедура ПолучателиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   
    СтандартнаяОбработка=Ложь;   
    Элементы.Получатели.ДобавитьСтроку();
    стрТЧ= Элементы.Получатели.ТекущиеДанные;
    стртч.единицаИзмерения = ВыбранноеЗначение;
    КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
67 Сообщений
antoneus antoneus
32 Сообщений
Ивашка
28 Сообщений
neek666
25 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
alexandr_ll
13 Сообщений
Алексей_1985_06
12 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 582
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск