Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 05:25

Запрет на проведение документа по условию 8.3

Автор lelik13121991, 12 мар 2017, 12:55

0 Пользователей и 1 гость просматривают эту тему.

lelik13121991

Требуется проверить отмечено ли поле ДеньгиПолучены. В случае если нет, то требуется при попытке проведения дать отказ на проведение, но не на запись.
Создаю событие ПередЗаписью в форме документа. Но не работает. Если убираю условие по режиму записи, то не дает даже просто записать.

&НаКлиенте
Процедура ПередЗаписью(Отказ, РежимЗаписи)
Если РежимЗаписи = РежимЗаписи.Проведение И Объект.ДеньгиПолучены = Ложь
Тогда Сообщить("Для проведения, необходимо отметить Деньги Получены");
Отказ = Истина;
КонецЕсли;
КонецПроцедуры


Заранее гранд мерси всем

alex0402

&НаКлиенте
Процедура ПередЗаписью(Отказ, РежимЗаписи)
    Если РежимЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение И Объект.ДеньгиПолучены = Ложь
        Тогда Сообщить("Для проведения, необходимо отметить Деньги Получены");
        Отказ = Истина;
    КонецЕсли;
КонецПроцедуры
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск