Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2021, 08:39
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Запрет на проведение документа по условию 8.3  (Прочитано 10427 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lelik13121991

  • *
  • Регистрация: 2016-10-30
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
Требуется проверить отмечено ли поле ДеньгиПолучены. В случае если нет, то требуется при попытке проведения дать отказ на проведение, но не на запись.
Создаю событие ПередЗаписью в форме документа. Но не работает. Если убираю условие по режиму записи, то не дает даже просто записать.

&НаКлиенте
Процедура ПередЗаписью(Отказ, РежимЗаписи)
Если РежимЗаписи = РежимЗаписи.Проведение И Объект.ДеньгиПолучены = Ложь
Тогда Сообщить("Для проведения, необходимо отметить Деньги Получены");
Отказ = Истина;
КонецЕсли;
КонецПроцедуры

Заранее гранд мерси всем


Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
&НаКлиенте
Процедура ПередЗаписью(Отказ, РежимЗаписи)
    Если РежимЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение И Объект.ДеньгиПолучены = Ложь
        Тогда Сообщить("Для проведения, необходимо отметить Деньги Получены");
        Отказ = Истина;
    КонецЕсли;
КонецПроцедуры
Спасибо за Сказать спасибо


Теги:
 

Как обратиться к элементам выделеной строки табличной части документа?

Автор Пирожок СповидломРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2942
Последний ответ 06 Мая 2016, 03:07
от cska-fanat-kz
Условие запрета редактирования документа

Автор IdzymiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1129
Последний ответ 13 Июн 2016, 11:26
от cska-fanat-kz
Запись реквизита из формы документа

Автор c_andreyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2208
Последний ответ 14 Окт 2015, 17:32
от дфтын
Реквизит формы документа не заполняется

Автор kaidjРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2086
Последний ответ 20 Ноя 2015, 11:11
от ferrari314
Как передать номер строки в табличной части документа

Автор NamikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8549
Последний ответ 14 Мая 2015, 07:18
от Namik

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
69 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
neek666
33 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
25 Сообщений
KATERINA 861
18 Сообщений
Алексей_1985_06
17 Сообщений
SSC
13 Сообщений
alexandr_ll
12 Сообщений
BuhRust
10 Сообщений

* Кто онлайн

  • Точка Гостей: 426
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск