Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 сен 2021, 21:14

Авто постановка значений в документе на основании выбора значения реквизита

Автор Константин5825, 11 мар 2017, 23:15

0 Пользователей и 1 гость просматривают эту тему.

Константин5825

Доброго времени суток!

У меня есть документ - Заявка на перевозку.
В нем 3 реквизита которые меня щас интересуют.
КонтактКлиента,Телефон,Емайл.

Так же есть справочник - ПредставителиКлиентов с реквизитами КонтактКлиента,Телефон,Емайл.

Я заполняю реквизит в документе выбором нужного мне КонтактаКлиента.

А вот дальше я не могу понять как сделать авто подстановку данных в реквизиты телефон и емайл.

Для КонтактаКлиента делаю событие при изменении на клиенте и сервере.
А с самой процедурой проблемы как не писал все глухо((((

Буду очень признателен за разъяснение!

Norfolk

Цитата: Константин5825 от 11 мар 2017, 23:15
Доброго времени суток!

У меня есть документ - Заявка на перевозку.
В нем 3 реквизита которые меня щас интересуют.
КонтактКлиента,Телефон,Емайл.

Так же есть справочник - ПредставителиКлиентов с реквизитами КонтактКлиента,Телефон,Емайл.

Я заполняю реквизит в документе выбором нужного мне КонтактаКлиента.

А вот дальше я не могу понять как сделать авто подстановку данных в реквизиты телефон и емайл.

Для КонтактаКлиента делаю событие при изменении на клиенте и сервере.
А с самой процедурой проблемы как не писал все глухо((((

Буду очень признателен за разъяснение!
Показывайте что наваяли в процедуре, будем смотреть.

Константин5825

Цитата: Norfolk от 12 мар 2017, 10:26
Цитата: Константин5825 от 11 мар 2017, 23:15
Доброго времени суток!

У меня есть документ - Заявка на перевозку.
В нем 3 реквизита которые меня щас интересуют.
КонтактКлиента,Телефон,Емайл.

Так же есть справочник - ПредставителиКлиентов с реквизитами КонтактКлиента,Телефон,Емайл.

Я заполняю реквизит в документе выбором нужного мне КонтактаКлиента.

А вот дальше я не могу понять как сделать авто подстановку данных в реквизиты телефон и емайл.

Для КонтактаКлиента делаю событие при изменении на клиенте и сервере.
А с самой процедурой проблемы как не писал все глухо((((

Буду очень признателен за разъяснение!
Показывайте что наваяли в процедуре, будем смотреть.


Спасибо! Но сам допер)))
Вот что получилось)
&НаКлиенте   
Процедура КонтактКлиентаПриИзменении(Элемент)//Получить контакты представителя клиента
Объект.ТелефонЗаказчика = ПолучитьТелефонЗаказчика(Объект.КонтактКлиента);
Объект.ЕмайлАдресЗаказчика = ПолучитьЕмайлАдресЗаказчика(Объект.КонтактКлиента);
КонецПроцедуры

&НаСервере
Функция ПолучитьТелефонЗаказчика(КонтактКлиента)
Возврат КонтактКлиента.Телефон;
    КонецФункции
Функция ПолучитьЕмайлАдресЗаказчика(КонтактКлиента)
Возврат КонтактКлиента.Email;
КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск