Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 сен 2021, 20:26

Заполнение данными в цикле РН

Автор c_andrey, 28 фев 2017, 14:05

0 Пользователей и 1 гость просматривают эту тему.

c_andrey

Добрый день. 1с 8.2 файловая обычный интерфейс.

Есть реквизит ДатаИзготовления в табличной части Рн.

Она все отлично отрабатывает только заполняет колонку "ДатаИзготовления" на какой номенклатуре стоишь.
А нужно что вы по всем колонкам (ДатаИзготовления)таблице пробежалась подскажите как это реализовать пробовал через "//Пока Выборка.Следующий() Цикл что не получилось.



Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

если СтрокаТабличнойЧасти.ДатаИзготовления=Дата(1,1,1,0,0,0)
тогда
СтрокаТабличнойЧасти.ДатаИзготовления= Дата;
НоменклатураОбъект.ДатаИзготовления = Дата;
НоменклатураОбъект.Записать();
конецЕсли;

КонецПроцедуры

alex0402


Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

Для каждого СтрокаТабличнойЧасти из ТабличнаяЧасть Цикл
     если СтрокаТабличнойЧасти.ДатаИзготовления=Дата(1,1,1,0,0,0) тогда       
СтрокаТабличнойЧасти.ДатаИзготовления= Дата;
НоменклатураОбъект = СтрокаТабличнойЧасти.ПолучитьОбъект();
НоменклатураОбъект.ДатаИзготовления = Дата;
НоменклатураОбъект.Записать(); конецЕсли;
КонецПроцедуры

Спасибо за Сказать спасибо

c_andrey

Ок спасибо.

Ошибку бьет

Переменная не определена (ТабличнаяЧасть)
Для каждого СтрокаТабличнойЧасти из <<?>>ТабличнаяЧасть Цикл

LexaK

Цитировать
НоменклатураОбъект = СтрокаТабличнойЧасти.ПолучитьОбъект();

Незачет! :befhbt:
(тут ошибка)
ответ Понравился? (в смысле пригодился?)

alex0402

так надо свою т.ч. подставить...
Спасибо за Сказать спасибо

c_andrey

Цитата: LexaK от 28 фев 2017, 14:30
Цитировать
НоменклатураОбъект = СтрокаТабличнойЧасти.ПолучитьОбъект();

Незачет! :befhbt:
(тут ошибка)

Спасибо. Есть такое конечно. Или нужно по другому?
Добавлено: 28 фев 2017, 14:38


Спасибо всем!!!

Цикл заработал.:ooifh:

LexaK

что за переменная НоменклатураОбъект? Зачем в Номенклатуре каждый раз менять дату производства?
просто заполнение в табличной части ДатаИзготовления (если конечно есть такой реквизит в ТЧ) датой документа

Для каждого СтрокаТабличнойЧасти из <ВашаТабличнаяЧасть> Цикл
    если Не ЗначениеЗаполнено(СтрокаТабличнойЧасти.ДатаИзготовления) тогда       
        СтрокаТабличнойЧасти.ДатаИзготовления = Дата;
    конецЕсли;
КонецПроцедуры
ответ Понравился? (в смысле пригодился?)

c_andrey

Цитата: LexaK от 28 фев 2017, 14:46
что за переменная НоменклатураОбъект? Зачем в Номенклатуре каждый раз менять дату производства?
просто заполнение в табличной части ДатаИзготовления (если конечно есть такой реквизит в ТЧ) датой документа

Для каждого СтрокаТабличнойЧасти из <ВашаТабличнаяЧасть> Цикл
    если Не ЗначениеЗаполнено(СтрокаТабличнойЧасти.ДатаИзготовления) тогда       
        СтрокаТабличнойЧасти.ДатаИзготовления = Дата;
    конецЕсли;
КонецПроцедуры


Так и поступил как вы написали.:D

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск