Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 06:09

обработка слау методом гаусса

Автор Gektor, 27 фев 2017, 08:46

0 Пользователей и 1 гость просматривают эту тему.

Gektor

Помогите подправить код студенту.Заранее  спасибо.
Перем k ;
Перем  j;
Перем a;
Перем b;
Перем d;
Перем i;
  Перем x;
         Перем n;
Для  k = 1 По k=3 Цикл
        Для j = k + 1 По k Цикл
            d = a[j][k]/a[k][k];
            Для i = k по k Цикл
                a[j] = a[j] - d * a[k];
            КонецЦикла;   
            b[j] = b[j] - d * b[k];
        КонецЦикла;   
    КонецЦикла; 
       
   Для k=1 По k=-3 Цикл 
      Для  k = 1 По k=-3  Цикл
                      d = 0;
              Для j = k + 1 По j=3 Цикл
               s = a[k][j] * x[j]; // формула (4)
                    d = d + s;
               
                                  
                  x[k] = (b[k] - d) / a[k][k];
               КонецЦикла ;
            КонецЦикла ;
                      КонецЦикла ;
               
                    Для  i = 1 По i=3 Цикл
                     КонецЦикла;
                  Сообщить ( i );
                    Сообщить ( k );
                   
                         Сообщить ( n );

Gektor

Создать обработку позволяющую решать СЛАУ методом Гауса. Для этого
Разместить на форме обработки табличную часть с 4 колонками.
В колонках храниться значения типа число(15.2). Каждое из чисел это коэффициенты линейного уравнения. Все вместе они образуют СЛАУ.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск