Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 окт 2021, 23:25

Требуется совет по подстановке в табличную часть данных из справочника

Автор lelik13121991, 25 фев 2017, 23:21

0 Пользователей и 1 гость просматривают эту тему.

lelik13121991

Собственно требуется в документе РеализацияМатериалов требуется чтобы в табличной части при выборе материала автоматом подставлялась стартовая цена из справочника.

Я набросал код, но он не работает. Заранее спасиб всем :)

&НаСервере
функция получить_цену(услуга)
    возврат Услуга.СтартоваяЦена;   
КонецФункции

&НаКлиенте
Процедура УслугиУслугаПриИзменении(Элемент)
    Строка = Элементы.Услуга.ТекущиеДанные;
    Если Строка <> Неопределено Тогда
        Строка.СтартоваяЦена = получить_цену(Строка.Материал);
    КонецЕсли
КонецПроцедуры

Artjomrgv

Можно конечно и код изменить, но в твоем случае стартовая цена это подчиненное поле справочника материалы, просто перенеси его в форму.

lelik13121991

Хм... Не совсем понял что вы имели ввиду.
Но, в принципе, проблема решилась путем привязки вышеуказанного кода к моменту изменения реквизита "Материал"

ilnur75

наверное имели ввиду к привязке к номенклатуре материала, т.е. при изменении номенклатуры у вас подставляется   стоимость услуги по данному материалу.
а услуга равно как материал или доставка и т.п. это полагаю некий критерий, по которому можно составить алгоритм выбора.

Artjomrgv

Цитата: lelik13121991 от 26 фев 2017, 03:33
Хм... Не совсем понял что вы имели ввиду.
Но, в принципе, проблема решилась путем привязки вышеуказанного кода к моменту изменения реквизита "Материал"

В твоей конфигурации у справочника материалы есть реквизит стартовая цена, в форме документа в правой части если ты развернешь реквизит материалы ты его увидишь. Достаточно перетянуть его в форму документа, а не создавать новый реквизит табличной части.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск