Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 окт 2021, 20:27

Помогите с УПП 1с 8.3

Автор AndreyV, 22 фев 2017, 09:52

0 Пользователей и 1 гость просматривают эту тему.

AndreyV

Добрый день!!! Я начинающий, так что не судите строго! Суть проблемы такой у нас добавлен в 1с УПП автомобильный модуль РАРУС, но он не работает корректно. При выводе документа на печать не заполняет оборотную страницу. Может кто сталкивался с такой проблемой? помогите плз...

AndreyV

//печатаем обратную сторону п/л
   Если ФлагПечати <> 1 Тогда
         
      Обл   = Макет.ПолучитьОбласть("Оборотная");
         
      Обл.Параметры.ВодительСдал   = уатОбщегоНазначенияТиповые.уатФамилияИнициалыФизЛица(Водитель1);
      Обл.Параметры.ПринялДиспетчер   = уатОбщегоНазначенияТиповые.уатФамилияИнициалыФизЛица(ВыдалДиспетчер);
         
      ТабДокумент.Вывести(Обл);
         
   КонецЕсли;
      
   Возврат ТабДокумент;

Norfolk

Цитата: AndreyV от 23 фев 2017, 08:13
//печатаем обратную сторону п/л
   Если ФлагПечати <> 1 Тогда
         
      Обл   = Макет.ПолучитьОбласть("Оборотная");
         
      Обл.Параметры.ВодительСдал   = уатОбщегоНазначенияТиповые.уатФамилияИнициалыФизЛица(Водитель1);
      Обл.Параметры.ПринялДиспетчер   = уатОбщегоНазначенияТиповые.уатФамилияИнициалыФизЛица(ВыдалДиспетчер);
         
      ТабДокумент.Вывести(Обл);
         
   КонецЕсли;
      
   Возврат ТабДокумент;
В отладчике что видите? В структуру "Если" зашел? Если зашел - тогда у вас нет данных по "Водитель" и "Диспетчер".

AndreyV

Так что я сделал! Установил параметры для ячеек и прописал след.
//печатаем обратную сторону п/л
      Если ФлагПечати <> 1 Тогда
         
         Обл   = Макет.ПолучитьОбласть("Оборотная");

         Обл.Параметры.ВодительСдал      = уатОбщегоНазначенияТиповые.уатФамилияИнициалыФизЛица(Водитель1);
         Обл.Параметры.ПринялДиспетчер   = уатОбщегоНазначенияТиповые.уатФамилияИнициалыФизЛица(ВыдалДиспетчер);
         
         Если ТранспортноеСредство.Модель.НаличиеСпидометра Тогда
            Пробег = уатОбщегоНазначения.уатРазностьПоказанийСчетчика(СпидометрВыезда,СпидометрВозвращения);
         Иначе
            Пробег = 0;
         КонецЕсли;
         
         РасчетВремени();
         
         мВесБочки = 0;
         
         Для Каждого ПрицепТС Из Прицепы Цикл
            мВесБочки = мВесБочки + ПрицепТС.ТС.Модель.СобственныйВес;
         КонецЦикла;
         
         мКоличествоЕздок = 0;
         мКоличествоКмГруз = 0;
         мКоличествоКмСГрузом = 0;
         мКоличествоТонн = 0;
         
         Для Каждого ТекСтрока Из Задание Цикл
            мКоличествоЕздок = мКоличествоЕздок + ТекСтрока.КоличествоЕздок;
            мКоличествоКмГруз = мКоличествоКмГруз + ТекСтрока.КоличествоКмГруз;
            мКоличествоТонн = мКоличествоТонн + ТекСтрока.КоличествоТонн;
         КонецЦикла;   
         
         мВесБочки1 = Пробег * мВесБочки;
         мКоличествоКмСГрузом = мКоличествоКмГруз + мКоличествоКмГруз * мКоличествоЕздок;
         мКоличествоЧасов = уатОбщегоНазначения.уатВремяВЧЧ_ММ(мВремяВНаряде);
         
         Обл.Параметры.ВсегоТКМ = мКоличествоТонн * мКоличествоКмСГрузом * мКоличествоЕздок + мВесБочки1;
         Обл.Параметры.ПробегОбщийТС = Пробег;
         Обл.Параметры.ЕздокВсего = мКоличествоЕздок;
         Обл.Параметры.ТоннВсего = мКоличествоТонн * мКоличествоЕздок;
         Обл.Параметры.ПробегСГрузомПрицеп = мКоличествоКмГруз * мКоличествоЕздок;
         Обл.Параметры.ПробегОбщийПрицеп = мКоличествоКмГруз * мКоличествоЕздок;
         Обл.Параметры.ВремяВНарядеТС = мКоличествоЧасов;
         Для Каждого ТекСтрока Из РасходГСМ Цикл
            Обл.Параметры.РасходФактический = ТекСтрока.РасходПоФакту;
            Обл.Параметры.РасходПоНорме1 = ТекСтрока.РасходПоНорме;
         КонецЦикла;
         ТабДокумент.Вывести(Обл);
      КонецЕсли;
Добавлено: 13 мар 2017, 10:30


Теперь все заполняется (ну что требовалось) только хотелось бы знать какие ошибки сделал... для себя

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск