Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 сен 2021, 13:50

Не выходит передать данные на клиент для последующей обработки.

Автор Рексарыч, 17 фев 2017, 14:29

0 Пользователей и 1 гость просматривают эту тему.

Рексарыч

Всем доброго времени суток, товарищи!

Конфигурация: "ERP УП 2".

По условию задачи требуется сделать так, чтобы у пользователя формировался отчёт, который он выберет в документе, нажав на кнопку "Печать" (наверное более нормальным языком это можно назвать, как "ПечатнаяФорма").

Проблема в том, что ".показать()" на сервере не работает, но когда я пытался каким-либо образом поймать возвращаюее значении функции "Печать" на клиенте - ничего не выходило. Прошу помочь с данной проблемой.


&НаСервере
Функция Печать(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт

УстановитьПривилегированныйРежим(Истина);

Макет = ПолучитьМакетНаСервере();

ТабличныйДокумент = Новый ТабличныйДокумент;

// Зададим параметры макета по-умолчанию
ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПеремещениеТоваров_ТОРГ13_";

Запрос = Новый Запрос(
"текст запроса");

Запрос.УстановитьПараметр("ПеремещениеТоваров", ОбъектыНазначенияМассив[0]);
ТребованиеНакладнаяНаСпирт = Запрос.Выполнить().Выбрать();

//////////////////////////////////////////////////////////////////////////////

Пока ТребованиеНакладнаяНаСпирт.Следующий() Цикл

            //обрабатываю нужным образом данные

КонецЦикла;

Возврат ТабличныйДокумент;

КонецФункции

&НаСервере
Функция ПолучитьМакетНаСервере()
    Возврат РеквизитФормыВЗначение("Объект").ПолучитьМакет("ПФ_MXL_ТОРГ13");
КонецФункции

Kironten

Ну так используйте типовую процедуру печати в ЕРП и будет вам счастье:
Процедура ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, ИмяМакета, СинонимМакета, ТабличныйДокумент,
Картинка = Неопределено, ПолныйПутьКМакету = "", ИмяФайлаПечатнойФормы = Неопределено) Экспорт

Рексарыч

Kironten, спасибо Вам за помощь. :)

Забавно конечно в "1С" устроено: кнопки "Печать" и "Заполнение" позволяют подключить различные обработки и отчёты к ним, но, при этом, когда подключаешь к одной из них, то код совершенно разный нужно писать. Не вижу в этом логики, поскольку что обработку, что отчёт, можно подключить как туда, так и туда.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск