Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 11:51

Сортировка строк в печатной форме документа

Автор 10vital08, 16 фев 2017, 14:01

0 Пользователей и 1 гость просматривают эту тему.

10vital08

Добрый день, форумчане!
Ситуация такая:
я хочу организовать сортировку строк в печатной форме документа по выбору пользователя, а именно по: наименованию номенклатуры, длине наименования номенклатуры.

Подскажите пожалуйста, что для этого нужно сделать?

10vital08

Вот исходный модуль печати

Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   Макет = Документы.Реализация_товаров.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   Реализация_товаров.Дата,
   |   Реализация_товаров.Контрагент,
   |   Реализация_товаров.Номер,
   |   Реализация_товаров.Товары.(
   |      НомерСтроки,
   |      Номенклатура,
   |      Количество,
   |      Цена,
   |      Сумма
   |   )
   |ИЗ
   |   Документ.Реализация_товаров КАК Реализация_товаров
   |ГДЕ
   |   Реализация_товаров.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   Шапка = Макет.ПолучитьОбласть("Шапка");
   ОбластьТоварыШапка = Макет.ПолучитьОбласть("ТоварыШапка");
   ОбластьТовары = Макет.ПолучитьОбласть("Товары");
   ТабДок.Очистить();

   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;

      ТабДок.Вывести(ОбластьЗаголовок);

      Шапка.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Шапка, Выборка.Уровень());

      ТабДок.Вывести(ОбластьТоварыШапка);
      ВыборкаТовары = Выборка.Товары.Выбрать();
      Пока ВыборкаТовары.Следующий() Цикл
         ОбластьТовары.Параметры.Заполнить(ВыборкаТовары);
         ТабДок.Вывести(ОбластьТовары, ВыборкаТовары.Уровень());
      КонецЦикла;

      ВставлятьРазделительСтраниц = Истина;
   КонецЦикла;
   //}}
КонецПроцедуры

Как можно сделать сортировку по выбору пользователя(названию или длине названия номенклатуры)?

depb

правильнее было бы делать сортировку в самом документе, печатная форма выводит лишь результат.

10vital08

Цитата: depb от 16 фев 2017, 15:40
правильнее было бы делать сортировку в самом документе, печатная форма выводит лишь результат.
У меня задание такое, именно сортировка строк в печатной форме нужна

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск