Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 окт 2021, 20:08

Шаблоны функций

Автор Noobles, 16 фев 2017, 09:55

0 Пользователей и 1 гость просматривают эту тему.

Noobles

Здравствуйте!
Постоянно натыкаюсь на предопределённые функции с несколькими вариантами набора аргументов
Получить(<Период>, <Отбор>)
Получить(<Отбор>)
Как подобное реализовать своими силами?



LexaK

:D да это же элементарно! создаете процедуру с несколькими необязательными параметрами
при обращении передаете разное количество параметров, а внутри процедуры анализируете что передано в параметре
пример

Процедура Тест(Парам1 = Неопределено, Парам2 = Неопределено, Парам3 = Неопределено)
    Если Парам1 <> Неопределено Тогда
        //так же здесь можно проверить тип переданных данных и др.
        //выполняете какие-то настройки
    КонецЕсли;

    Если Парам2 <> Неопределено Тогда
        //так же здесь можно проверить тип переданных данных и др.
        //выполняете какие-то настройки
    КонецЕсли;

    //далее тело модуля

КонецПроцедуры;


//обращение к процедуре
Тест(ТекущаяДата(), СсылкаНаДокумент);
Тест("ПолучитьРезультат", РезульататТЗ, ТекущаяДата());
Тест();


ответ Понравился? (в смысле пригодился?)

Noobles

ну да я так и сделал, но в предопределённых функциях есть стрелочка выбора набора аргументов.

LexaK

В моей платформе 8.3.9 таких стрелок нет, но включена подсказка, при вводе процедуры после "(" или ","  подсказывается следующий параметр

да и потом не путайте встроенные функции (функционал платформы) со своими(программными)
уж не думаете ли вы что сама платформа написана на языке программирования 1С ?
ответ Понравился? (в смысле пригодился?)

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск