Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 05:17

Раскраска полей в журнале

Автор Dirc, 15 фев 2017, 10:40

0 Пользователей и 1 гость просматривают эту тему.

Dirc

Доброго времени суток.
Понимаю, что вопросов в этой теме была много, но прощу помощи чтобы разобраться с процессом составления условий для строк в журнале.
Задача банальная: Раскрасить разные строки резными цветами в зависимости от определённого критерия в колонке.
Всё для этого подготовил:
1)   Добавил библиотеку в 1С 7.7
2)   Создал колонку с формулой ПроверитьВид(), без условия таблица раскрашивается в заданный цвет всё работает.
3)   Проблема в написании условии, журнал документов имеет следующий вид.



Вопрос, как должно звучать условия, чтобы была раскраска по колонке Статуст:
Функция ПроверитьВид()
      Если ТУТ ДОЛЖНО БЫТЬ УСЛОВИЯ НА КОЛОНКУ СТАТУС="Выполнен" Тогда
         Возврат "BRUSH["+ПолучитьЦвет(204,204,204)+"]";
      ИначеЕсли ТУТ ДОЛЖНО БЫТЬ УСЛОВИЯ НА КОЛОНКУ СТАТУС ="Не выполнен" Тогда
         Возврат "FONT["+ПолучитьЦвет(0,0,0)+"] BRUSH["+ПолучитьЦвет(100,100,255)+"]";
      ИначеЕсли ТУТ ДОЛЖНО БЫТЬ УСЛОВИЯ НА КОЛОНКУ СТАТУС ="Выполнен (со счетом)" Тогда
         Возврат "BRUSH["+ПолучитьЦвет(221,221,255)+"]"
      КонецЕсли;
КонецФункции   

alexandr_ll

Ваш журнал в сообщении не виден

Dirc

https://yadi.sk/i/QmDmv7C23E6dXX
Или
https://1.downloader.disk.yandex.ru/preview/42d97f5ba4776a7cecf8e7c9d1e61619e0411fdd88065e234bae7fc6f5f63966/inf/50RfPXZ0Q6f9ZWTBxyLmL_uXPus-oxAv3IqlEhW6oqn5eCR3t22oQ-cr-x0Ce4A5dQfdmcveoFMrF9uOsQkqxQ%3D%3D?uid=137982579&filename=%D0%96%D1%83%D1%80%D0%BD%D0%B0%D0%BB.PNG&disposition=inline&hash=&limit=0&content_type=image%2Fpng&tknv=v2&size=1280x822
Добавлено: 17 фев 2017, 12:26


Нашёл решение сам B):
Если Статус=Константа.ВыпСтатус Тогда
            Возврат "FONT["+ПолучитьЦвет(0,0,0)+"] BRUSH["+ПолучитьЦвет(100,255,100)+"]";
      ИначеЕсли Статус=Константа.ОтложСтатус Тогда
            Возврат "FONT["+ПолучитьЦвет(0,0,0)+"] BRUSH["+ПолучитьЦвет(255,255,100)+"]";
      ИначеЕсли Статус=Константа.НевыпСтатус Тогда
         Возврат "FONT["+ПолучитьЦвет(0,0,0)+"] BRUSH["+ПолучитьЦвет(50,200,255)+"]";
      ИначеЕсли Статус=Константа.АхтунгСтатус Тогда
            Возврат "FONT["+ПолучитьЦвет(0,0,0)+"] BRUSH["+ПолучитьЦвет(255,50,100)+"]";
КонецЕсли; 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск