Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 15:52
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: ВыборНезаполненного  (Прочитано 764 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Сергей Данилов

  • *
  • Регистрация: 2017-02-03
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Бьюсь весь день помогите. :trhregerhg:
После "Автовыборнезаполнненого" открывается справочник все отлично.
Вопрос как сделать чтобы открывался в раскрытой группе выбора последнего элемента введенного списка к примеру Реализации.


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • *****
  • Регистрация: 2012-08-15
  • Сообщений: 7151
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
    • Skype: MuI_I_Ika
  • Профессия: Программист 1С
Для этого нужно изменить процедуру при выборе.

И при открытии формы устанавливать текущим элементом, предыдущий выбранный.

Но вообще для решения этого вопроса лучше использовать форму подбора, когда при выборе форма выбора не закрывается, а пользователь сразу переходит к выбору следующего элемента.

Оффлайн Сергей Данилов

  • *
  • Регистрация: 2017-02-03
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Для этого нужно изменить процедуру при выборе.

И при открытии формы устанавливать текущим элементом, предыдущий выбранный.

Но вообще для решения этого вопроса лучше использовать форму подбора, когда при выборе форма выбора не закрывается, а пользователь сразу переходит к выбору следующего элемента.
Спасибо что откликнулись.

Спасибо за наводку. Принцип понятен. Только вопрос а как выбрать предыдущий элемент создать через глобальную переменную или массив в модуле программы или есть короткий путь. Спасибо за помощь.

Оффлайн Tyts

  • Тыц
  • *
  • Регистрация: 2016-12-13
  • Сообщений: 17
  • РЕПУТАЦИЯ: 1
  • КПД: 6%
  • Подпись под аватаром
  • Профессия: Ученик 1С
Только вопрос а как выбрать предыдущий элемент
В форме списка.
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если ТипЗнч(Параметры)=Тип("Спр") Тогда
Элементы.Список.ТекущаяСтрока = Параметры;
    КонецЕсли
КонецПроцедуры

Оффлайн Сергей Данилов

  • *
  • Регистрация: 2017-02-03
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
глСтрока массив данных ТекущаяСтрока
///

     СтандартнаяОбработка = Ложь;
          ПараметрыФормы = Новый Структура("Отбор",глСтрока.Номенклатура);
     ОткрытьФорму("Справочник.Номенклатура.Форма.ФормаВыбора",ПараметрыФормы,);
       
///
Вообщем просто открывает Справочник . работаю дальше.. Нужно что-то с родителем придумать наверное.
Добавлено: 03 Фев 2017, 22:04

:trhregerhg: помогите тупик весь день вот это получилось нерабочее гавно. :dfbsdfbsdf:

Процедура ТоварыНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

        СтандартнаяОбработка = Ложь;
        СтрЭлемент = Новый Структура;
        ПолучитьНоменклатура (стрЭлемент,глСтрока.Номенклатура);
       
        ПараметрыФормы = Новый Структура("Отбор",стрЭлемент);
        ОткрытьФорму("Справочник.Номенклатура.Форма.ФормаВыбора",ПараметрыФормы,);

КонецПроцедуры

  &НаСервере
  Процедура ПолучитьНоменклатура (стрЭлемент,Номенклатура)
     стрЭлемент.Вставить("Родитель",Номенклатура);
     стрЭлемент.Вставить("ЭтоГруппа", Ложь);
  КонецПроцедуры

Последний раз редактировалось: Сергей Данилов; 03 Фев 2017, 22:04. Причина: Объединение сообщений


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 618
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск