Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2021, 09:29
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Просчелкать поля\ENTER и расчет  (Прочитано 1416 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн JOG

  • **
  • Регистрация: 2014-06-15
  • Сообщений: 79
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
Здравствуйте! Подскажите пожалуйста как отследить событие просчелкивания полей?
Задача такая: в документе Поле1 + Поле2= Поле3. В Поле1 всегда вводим число, а второе можем ввести, а можем просто просчелкать(в результате должно получиться Поле3=Поле1). Как мне посчитать сумму полей, не прибегая к процедуре ПриИзменении Поля2?


Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
Прописать ПриИзменении в Поле1 и Поле2
Спасибо за Сказать спасибо

Оффлайн JOG

  • **
  • Регистрация: 2014-06-15
  • Сообщений: 79
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
Прописать ПриИзменении в Поле1 и Поле2
Не подходит. Мне нужна возможность миновать заполнение Поля2 путём просчелкивания или вообще к нему не обращаться, но именно после него должна просчитаться сумма.
Или, например, было бы замечательно отследить переход на Поле3. Что-то наподобии
Процедура ПриПеремещенииКурсораНаПоле3
//суммирую поля1 и 2
КонецПроцедуры
А как отследить выделено Поле3 или нет?

Оффлайн has

  • *****
  • Регистрация: 2011-01-28
  • Сообщений: 1315
  • РЕПУТАЦИЯ: 286
  • КПД: 22%
  • Профессия: Программист 1С
ну и пиши в событии ПриИзменении и у поля1 и у поля2, что-то типа
Если Не ЗначениеЗаполнено(Поле2) Тогда
    Поле3 = Поле1;
Иначе
    Поле3 = Поле1 + Поле2
КонецЕсли;

Оффлайн JOG

  • **
  • Регистрация: 2014-06-15
  • Сообщений: 79
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
ну и пиши в событии ПриИзменении и у поля1 и у поля2, что-то типа
Если Не ЗначениеЗаполнено(Поле2) Тогда
    Поле3 = Поле1;
Иначе
    Поле3 = Поле1 + Поле2
КонецЕсли;
В самом деле, не подумал.Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
69 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
neek666
33 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
25 Сообщений
KATERINA 861
18 Сообщений
Алексей_1985_06
17 Сообщений
SSC
13 Сообщений
alexandr_ll
12 Сообщений
BuhRust
10 Сообщений

* Кто онлайн

  • Точка Гостей: 471
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск