Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 06:32

Просчелкать поля\ENTER и расчет

Автор JOG, 19 янв 2017, 11:32

0 Пользователей и 1 гость просматривают эту тему.

JOG

Здравствуйте! Подскажите пожалуйста как отследить событие просчелкивания полей?
Задача такая: в документе Поле1 + Поле2= Поле3. В Поле1 всегда вводим число, а второе можем ввести, а можем просто просчелкать(в результате должно получиться Поле3=Поле1). Как мне посчитать сумму полей, не прибегая к процедуре ПриИзменении Поля2?

alex0402

Прописать ПриИзменении в Поле1 и Поле2
Спасибо за Сказать спасибо

JOG

Цитата: alex0402 от 19 янв 2017, 11:41
Прописать ПриИзменении в Поле1 и Поле2
Не подходит. Мне нужна возможность миновать заполнение Поля2 путём просчелкивания или вообще к нему не обращаться, но именно после него должна просчитаться сумма.
Или, например, было бы замечательно отследить переход на Поле3. Что-то наподобии
Процедура ПриПеремещенииКурсораНаПоле3
//суммирую поля1 и 2
КонецПроцедуры

А как отследить выделено Поле3 или нет?

has

ну и пиши в событии ПриИзменении и у поля1 и у поля2, что-то типа

Если Не ЗначениеЗаполнено(Поле2) Тогда
    Поле3 = Поле1;
Иначе
    Поле3 = Поле1 + Поле2
КонецЕсли;

JOG

Цитата: has от 19 янв 2017, 14:11
ну и пиши в событии ПриИзменении и у поля1 и у поля2, что-то типа

Если Не ЗначениеЗаполнено(Поле2) Тогда
    Поле3 = Поле1;
Иначе
    Поле3 = Поле1 + Поле2
КонецЕсли;

В самом деле, не подумал.Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск