Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2021, 20:37

Не отрабатывает ОбработкаПолученияПредставления()

Автор ferrari314, 18 янв 2017, 09:20

0 Пользователей и 2 гостей просматривают эту тему.

ferrari314

Всем привет. Запилил в  модуль менеджера загугленный код формирования представления.

Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Представление = Данные.Вид + " от " + Данные.Дата + " #№" + Данные.Номер;
КонецПроцедуры

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Поля.Добавить("Вид");
Поля.Добавить("Дата");
Поля.Добавить("Номер");
КонецПроцедуры

Результата нет. Объект перезаписывал - представление дефолтное.
В чем проблема может быть?
плюсы в репу!

LexaK

Попробуйте явное или не явное преобразование к строке, по крайней мере у меня без этого появлялась ошибка

Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    //добавлено "" +
    Представление = "" + Данные.Вид + " от " + Данные.Дата + " #№" + Данные.Номер;
КонецПроцедуры

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;

    //по примеру добавил очистку полей, перед формированием
    Поля.Очистить();

    Поля.Добавить("Вид");
    Поля.Добавить("Дата");
    Поля.Добавить("Номер");
КонецПроцедуры


и на всякий случай проверьте в конфигураторе в свойствах конфигурации Режим совместимость,
не помню с какой версии 8.3... появилась эта возможность. Если у вас стоит совместимость 8.2 (например)
то работать не будет. 
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск