Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2021, 15:01

Суммирование данных табличной части в данные формы

Автор vla-sky, 17 янв 2017, 14:57

0 Пользователей и 1 гость просматривают эту тему.

vla-sky

Добрый день! Создан новый вид документа с Реквизитами и Табличной частью.
Необходимо, чтобы в данных одного Реквизита происходило суммирование определенного столбца Табличной части по каждой строке (сколько бы их ни было и при добавлении новых.
Помогите, пожалуйста, если не сложно как прописать данную формулу.

Конфигурация: Комплексная автоматизация, редакция 1.1 (1.1.65.1)
Обычное приложение (толстый клиент)

alex0402

У табличной части на форме есть Событие ПриИзменении.
В этом событии прописать
Объект.ИмяРеквизита = 0;
Для каждого тСтрока из Объект.ИмяТабличнойЧасти Цикл
    Объект.ИмяРеквизита = Объект.ИмяРеквизита + тСтрока.ИмяРеквизита;
КонецЦикла;
Спасибо за Сказать спасибо

LexaK

ну зачем так сложно?
Цитировать
Для каждого тСтрока из Объект.ИмяТабличнойЧасти Цикл
    Объект.ИмяРеквизита = Объект.ИмяРеквизита + тСтрока.ИмяРеквизита;
КонецЦикла;

у табличной части или коллекции формы есть метод Итог()
поэтому подсчет суммы может выглядеть так


Процедура ВашаТЧПриИзменении(Элемент)
    Объект.СтоимостьУслуги = Объект.ВашаТЧ.Итог("СтоимостьУслуги");
КонецПроцедуры
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск