Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 сен 2021, 13:36

Настройка смс-порталов (sms4b) для "ДАЛИОН: АвтоБизнес", ред. 1.3 (1.3.4.32), платформа 8.2

Автор Оксана Новоч, 16 янв 2017, 15:35

0 Пользователей и 1 гость просматривают эту тему.

Оксана Новоч

Добрый день. Помогите, пожалуйста, новичку настроить рассылку смс-собщений из Конфы "ДАЛИОН: АвтоБизнес", ред. 1.3 (1.3.4.32), платформа 8.2.
В ин-те есть инструкция http://auto.dalion.ru/upload/file/pdf/instructions/sms_email.pdf, в ней написано: "Можно открыть в конфигураторе модуль справочника SMSпорталы и из него скопировать образец процедуры .... И подправить эту процедуру под другой SMS портал.".
В модуль справочника SMSпорталы я нашла процедуры, скопировала, поместила куда надо (как в инструкции написано). Но как надо настроить под sms4b - я не знаю.
пробовала так
...
Если ПустаяСтрока(Логин) или ПустаяСтрока(Пароль) Тогда
      Ошибки=Ошибки+" Не указан логин или пароль";
   КонецЕсли;
   Если ПустаяСтрока(Ошибки) Тогда
      ИмяФайлаОтвета=ПолучитьИмяВременногоФайла("txt");
      Соединение = Новый HTTPСоединение("sms4b.ru/webservices/sms.asmx";);
      Параметры="?login="+СокрЛП(Логин)+"&psw="+СокрЛП(Пароль);
      Параметры=Параметры+"&sender="+СокрЛП(Отправитель);
      Параметры=Параметры+"&phones=7"+Прав(СокрЛП(Номер),10)+"&mes=";
      Если Транслит Тогда
         Параметры=Параметры+URLEncode(Транслит(Текст));
      Иначе
         Параметры=Параметры+URLEncode(Текст);
      КонецЕсли;
      Попытка
         Соединение.Получить(Параметры, ИмяФайлаОтвета);
      Исключение
         Ошибки=Ошибки+" "+ОписаниеОшибки();
      КонецПопытки;
      Если ПустаяСтрока(Ошибки) Тогда
         ЧтениеТекста = Новый ЧтениеТекста(ИмяФайлаОтвета);
         Ответ=ЧтениеТекста.Прочитать();
         Если Найти(Ответ,"ERROR")>0 Тогда
            Ошибки=Ошибки+" Ошибка портала: "+Ответ;
         КонецЕсли;
      КонецЕсли;
   КонецЕсли;
...
( выдает ошибку Ошибка при вызове метода контекста (Получить): Файл не обнаружен '?login=AutoluxN&psw=Ifkfvjaa&sender=Я&phones=79896170462&mes=%CF%F0%EE%E1%E0': Ошибка работы с Интернет:  ресурс не найден (404))

Oldman06

У sms4b на сайте есть конфа 1с для работы с смс-сервисом. Посмотрите там. Сам, года 4 назад, внедрял в свою конфу их модули. А штатными средствами вашей конфы, сомневаюсь что получиться.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск