Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 сен 2021, 16:58

Создание Отчёта на основание Формы списка Документа

Автор Владимир Ковалев, 12 янв 2017, 13:28

0 Пользователей и 1 гость просматривают эту тему.

Владимир Ковалев

Платформа 7.7 (7.70.027)
Конфигурация Самописка

Всем Доброго времени суток.
Есть Документ "Заказ Покупателя"(Снимок0) В котором по мимо списка номенклатуры контрагента имеется поля выбора склад резерва(Справочник.Склады). 
Задача создать отчет который будет отбирать документ за период и конкретным складом резерва(Форма отчёта Снимок).
И отображать в Печатной Форме Дату создания Документа, Номер Документа, Покупателя, Сумму в документе(Снимок1).
Меня Конкретно интересует что вставлять в модуль отчёта.

По коду в данный момент полный НОЛЬ.

alex0402

Цитата: Владимир Ковалев от 12 янв 2017, 13:28По коду в данный момент полный НОЛЬ.

Документ = СоздатьОбъект("Документ.ЗаказПокупателя");
Документ.ВыбратьДокументы(ДатаНачала,ДатаОкончания);

Табл = СоздатьОбъкет("ТаблицаЗначений");
//... добавить колонки.
Пока Документ.ПолучитьДокумент() = 1 Цикл

    текДокумент = Документ.ТекущийДокумент();
    текДокумент.ВыбратьСтроки();
    Пока текДокумент.ПолучитьСтроку() = 1 Цикл
        Табл.НоваяСтрока();
        //Заполнить таблицы колонки;
    КонецЦикла;
    //Обработка таблицы значений;

    ТабДок = СоздатьОбъект("ТабличныйДокумент");
    Макет = ПолучитьМакет("ИмяМакет");
    Табл.ВыбратьСтроки();
    Пока Табл.ПолучитьСтроку() = 1 Цикл
        ТабДок.ВывестиСекцию() // здесь точно не помню как
    КонецЦикла;
    ТабДок.Показать();
КонецЦикла
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск