Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2021, 14:53

Не выполняется оператор ЕСЛИ

Автор mzforums, 07 янв 2017, 15:49

0 Пользователей и 1 гость просматривают эту тему.

mzforums

Добрый день.


Для каждого СтрокаТЧ Из ЗапасыКартами Цикл
Если СтрокаТЧ.Всего <> 0 Тогда
Группа = СтрокаТЧ.Номенклатура.ПолноеНаименование();
Если (Найти(Группа, "КОМП") = 1 ИЛИ
Найти(Группа, "УСЛ") = 1) Тогда
Если (СтрокаТЧ.ФормаОплаты = "Безналичные") Тогда
СуммаКартами = СуммаКартами + СтрокаТЧ.Всего;
ааа = 2017;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;


Не могу понять - почему не выполняется самое вложенное условие:
Если (СтрокаТЧ.ФормаОплаты = "Безналичные") Тогда

Отслеживаю в конфигураторе значение переменных - все в порядке.
Значение "СтрокаТЧ.ФормаОплаты" = Безналичные (при наведении курсора)

Может это из-за того, что тип СтрокаТЧ.ФормаОплаты - перечисления ?

sertak

Поставьте точку останова в этом месте и откройте Табло
Проверьте, что возвращает сравнение СтрокаТЧ.ФормаОплаты = "Безналичные".
Как вы и предполагаете, дело в типе. Нужно исправить на что-то такое: СтрокаТЧ.ФормаОплаты = Перечисления.ФормыОплаты.Безналичные
Только проверьте, как именно называется нужное перечисление.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск