Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 23:51
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Ошибка при обновлении информационной базы  (Прочитано 5552 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн doll

  • *
  • Регистрация: 2017-01-01
  • Сообщений: 7
  • РЕПУТАЦИЯ: 1
  • КПД: 14%
  • Профессия: Программист 1С
При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(58, 2)}: Несовместимые типы "ВЫБОР"
<<?>>ВЫБОР"

Данная ошибка в Общем модуле. Длительность операции. 376 строка. Вот текст (376 строка отмечена цифрой):

Функция ЗаданиеВыполнено(Знач ИдентификаторЗадания) Экспорт
   
   Задание = НайтиЗаданиеПоИдентификатору(ИдентификаторЗадания);
   
   Если Задание <> Неопределено
      И Задание.Состояние = СостояниеФоновогоЗадания.Активно Тогда
      Возврат Ложь;
   КонецЕсли;
   
   ОперацияНеВыполнена = Истина;
   ПоказатьПолныйТекстОшибки = Ложь;
   Если Задание = Неопределено Тогда
      ЗаписьЖурналаРегистрации(НСтр("ru = 'Длительные операции.Фоновое задание не найдено'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
         УровеньЖурналаРегистрации.Ошибка, , , Строка(ИдентификаторЗадания));
   Иначе
      Если Задание.Состояние = СостояниеФоновогоЗадания.ЗавершеноАварийно Тогда
         ОшибкаЗадания = Задание.ИнформацияОбОшибке;
         Если ОшибкаЗадания <> Неопределено Тогда
            ПоказатьПолныйТекстОшибки = Истина;
         КонецЕсли;
      ИначеЕсли Задание.Состояние = СостояниеФоновогоЗадания.Отменено Тогда
         ЗаписьЖурналаРегистрации(
            НСтр("ru = 'Длительные операции.Фоновое задание отменено администратором'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка,
            ,
            ,
            НСтр("ru = 'Задание завершилось с неизвестной ошибкой.'"));
      Иначе
         Возврат Истина;
      КонецЕсли;
   КонецЕсли;
   
   Если ПоказатьПолныйТекстОшибки Тогда
       ТекстОшибки = КраткоеПредставлениеОшибки(ПричинаОшибки(Задание.ИнформацияОбОшибке));
376   ВызватьИсключение (ТекстОшибки);
   ИначеЕсли ОперацияНеВыполнена Тогда
      ВызватьИсключение(НСтр("ru = 'Не удалось выполнить данную операцию.
                            |Подробности см. в Журнале регистрации.'"));
   КонецЕсли;
   
КонецФункции

#КонецОбласти


Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Регистрация: 2015-03-12
  • Сообщений: 4543
  • РЕПУТАЦИЯ: 178
  • КПД: 4%
  • Проблемы в 1С решу удаленно дешево
  • Компания: Фрилансер - частное лицо
  • Профессия: Программист 1С
При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Много раз и устанавливал-обновлял модуль Битрикса для УТ11.2 и саму УТ11.2 с уже установленным модулем, но я не понимаю, о чём Вы пишите. Дайте ссылку на инструкцию, они все  открытом доступе и привяжите её цитаты к Вашей ситуации

Оффлайн doll

  • *
  • Регистрация: 2017-01-01
  • Сообщений: 7
  • РЕПУТАЦИЯ: 1
  • КПД: 14%
  • Профессия: Программист 1С
При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Много раз и устанавливал-обновлял модуль Битрикса для УТ11.2 и саму УТ11.2 с уже установленным модулем, но я не понимаю, о чём Вы пишите. Дайте ссылку на инструкцию, они все  открытом доступе и привяжите её цитаты к Вашей ситуации

https://dev.1c-bitrix.ru/learning/course/?COURSE_ID=42&LESSON_ID=7184
Предпоследний и последний шаг по данной инструкции:

Выполните обновление данных в базе 1С. Для этого откройте Сервис > Параметры. На вкладке Запуск 1С: Предприятия укажите параметр запуска ЗапуститьОбновлениеИнформационнойБазы и нажмите Ок:

После запуска отладки начинает идет процесс обновления ИБ, но на 91% процесс останавливается и выдает ошибку в Общем модуле. Длительность операции. 376 строка:

"Ошибка в схеме компоновки данных
по причине:
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(58, 2)}: Несовместимые типы "ВЫБОР"
<<?>>ВЫБОР"

Привожу код функции где прописана строка:

Функция ЗаданиеВыполнено(Знач ИдентификаторЗадания) Экспорт
   
   Задание = НайтиЗаданиеПоИдентификатору(ИдентификаторЗадания);
   
   Если Задание <> Неопределено
      И Задание.Состояние = СостояниеФоновогоЗадания.Активно Тогда
      Возврат Ложь;
   КонецЕсли;
   
   ОперацияНеВыполнена = Истина;
   ПоказатьПолныйТекстОшибки = Ложь;
   Если Задание = Неопределено Тогда
      ЗаписьЖурналаРегистрации(НСтр("ru = 'Длительные операции.Фоновое задание не найдено'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
         УровеньЖурналаРегистрации.Ошибка, , , Строка(ИдентификаторЗадания));
   Иначе
      Если Задание.Состояние = СостояниеФоновогоЗадания.ЗавершеноАварийно Тогда
         ОшибкаЗадания = Задание.ИнформацияОбОшибке;
         Если ОшибкаЗадания <> Неопределено Тогда
            ПоказатьПолныйТекстОшибки = Истина;
         КонецЕсли;
      ИначеЕсли Задание.Состояние = СостояниеФоновогоЗадания.Отменено Тогда
         ЗаписьЖурналаРегистрации(
            НСтр("ru = 'Длительные операции.Фоновое задание отменено администратором'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка,
            ,
            ,
            НСтр("ru = 'Задание завершилось с неизвестной ошибкой.'"));
      Иначе
         Возврат Истина;
      КонецЕсли;
   КонецЕсли;
   
   Если ПоказатьПолныйТекстОшибки Тогда
       ТекстОшибки = КраткоеПредставлениеОшибки(ПричинаОшибки(Задание.ИнформацияОбОшибке));
:^454^:   ВызватьИсключение (ТекстОшибки);
   ИначеЕсли ОперацияНеВыполнена Тогда
      ВызватьИсключение(НСтр("ru = 'Не удалось выполнить данную операцию.
                            |Подробности см. в Журнале регистрации.'"));
   КонецЕсли;
   
КонецФункции

#КонецОбласти










Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Регистрация: 2015-03-12
  • Сообщений: 4543
  • РЕПУТАЦИЯ: 178
  • КПД: 4%
  • Проблемы в 1С решу удаленно дешево
  • Компания: Фрилансер - частное лицо
  • Профессия: Программист 1С
Столько много букв, а самого главного не пишите - какова полная версия УТ 11.2 и версия модуля Битрикс, который Вы устанавливаете:
Соответствие версий и дат УТ 11.2 и Модули Битрикс (ссылки для скачивания)

Оффлайн doll

  • *
  • Регистрация: 2017-01-01
  • Сообщений: 7
  • РЕПУТАЦИЯ: 1
  • КПД: 14%
  • Профессия: Программист 1С
Столько много букв, а самого главного не пишите - какова полная версия УТ 11.2 и версия модуля Битрикс, который Вы устанавливаете:
Соответствие версий и дат УТ 11.2 и Модули Битрикс (ссылки для скачивания)

УТ 11.2.3.168. Версия модуля 6.0.3.4

Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Регистрация: 2015-03-12
  • Сообщений: 4543
  • РЕПУТАЦИЯ: 178
  • КПД: 4%
  • Проблемы в 1С решу удаленно дешево
  • Компания: Фрилансер - частное лицо
  • Профессия: Программист 1С
УТ 11.2.3.168. Версия модуля 6.0.3.4
И? Вы смотрели на соответствие версий?
В соответствии со ссылкой, которую я дал выше, самый актуальный/последний модуль Битрикс 6.0.3.4 сделан под УТ версии 11.2.3.108 и он понятия не имеет, что там могло появиться в УТ последующих версий

В лучшем случае Вы устанавливаете модуль Битрикс на УТ 11.2.3.108

Оффлайн doll

  • *
  • Регистрация: 2017-01-01
  • Сообщений: 7
  • РЕПУТАЦИЯ: 1
  • КПД: 14%
  • Профессия: Программист 1С
УТ 11.2.3.168. Версия модуля 6.0.3.4
И? Вы смотрели на соответствие версий?
В соответствии со ссылкой, которую я дал выше, самый актуальный/последний модуль Битрикс 6.0.3.4 сделан под УТ версии 11.2.3.108 и он понятия не имеет, что там могло появиться в УТ последующих версий

В лучшем случае Вы устанавливаете модуль Битрикс на УТ 11.2.3.108



Ошибка была при установке модуля! Не надо было менять режим совместимости. Спасибо


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
23 Сообщений
alexandr_ll
15 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск