Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 11:54

Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор doll, 01 янв 2017, 10:41

0 Пользователей и 1 гость просматривают эту тему.

doll

Добрый день! С Новым Годом! Помогите, пожалуйста, решить задачу:

При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(58, 2)}: Несовместимые типы "ВЫБОР"
<<?>>ВЫБОР"

Данная ошибка в Общем модуле. Длительность операции. 376 строка. Вот текст (376 строка отмечена цифрой):

Функция ЗаданиеВыполнено(Знач ИдентификаторЗадания) Экспорт
   
   Задание = НайтиЗаданиеПоИдентификатору(ИдентификаторЗадания);
   
   Если Задание <> Неопределено
      И Задание.Состояние = СостояниеФоновогоЗадания.Активно Тогда
      Возврат Ложь;
   КонецЕсли;
   
   ОперацияНеВыполнена = Истина;
   ПоказатьПолныйТекстОшибки = Ложь;
   Если Задание = Неопределено Тогда
      ЗаписьЖурналаРегистрации(НСтр("ru = 'Длительные операции.Фоновое задание не найдено'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
         УровеньЖурналаРегистрации.Ошибка, , , Строка(ИдентификаторЗадания));
   Иначе
      Если Задание.Состояние = СостояниеФоновогоЗадания.ЗавершеноАварийно Тогда
         ОшибкаЗадания = Задание.ИнформацияОбОшибке;
         Если ОшибкаЗадания <> Неопределено Тогда
            ПоказатьПолныйТекстОшибки = Истина;
         КонецЕсли;
      ИначеЕсли Задание.Состояние = СостояниеФоновогоЗадания.Отменено Тогда
         ЗаписьЖурналаРегистрации(
            НСтр("ru = 'Длительные операции.Фоновое задание отменено администратором'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка,
            ,
            ,
            НСтр("ru = 'Задание завершилось с неизвестной ошибкой.'"));
      Иначе
         Возврат Истина;
      КонецЕсли;
   КонецЕсли;
   
   Если ПоказатьПолныйТекстОшибки Тогда
       ТекстОшибки = КраткоеПредставлениеОшибки(ПричинаОшибки(Задание.ИнформацияОбОшибке));
376   ВызватьИсключение (ТекстОшибки);
   ИначеЕсли ОперацияНеВыполнена Тогда
      ВызватьИсключение(НСтр("ru = 'Не удалось выполнить данную операцию.
                            |Подробности см. в Журнале регистрации.'"));
   КонецЕсли;
   
КонецФункции

#КонецОбласти



AIFrame

Цитата: doll от 01 янв 2017, 10:41Данная ошибка в Общем модуле. Длительность операции. 376 строка. Вот текст (376 строка отмечена цифрой):
Она не там, а до этого момента. Где-то есть запрос кривой.
Поставь точку останова на 376 строке, выдели Задание.ИнформацияОбОшибке и нажми shift+f9, хоть текст посмотришь.


Теги: обновление 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск