Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 10:53

Как сделать выборку из данных документа основания для вывода на печать?

Автор Volta111, 30 дек 2016, 20:58

0 Пользователей и 1 гость просматривают эту тему.

Volta111

Здравствуйте! я новичок в 1с и не могу разобраться, помогите, плиз:
Мне нужно в печатной форме вывести данные из табличной части документа на основании которого был создан данный документ. Текущий документ табличной части не имеет.
Дорисовала в макете табличную часть и добавила следующий код в процедуру печати. Но выдает "поле товары не обнаружено". Что изменить в коде? Как правильно обратиться к документу на основании которого был создан?:dfbsdfbsdf:


    ДокументОснование = ДокументОснование.ПолучитьДокумент();

Запрос2 = Новый Запрос;
   Запрос2.Текст =
   "ВЫБРАТЬ
   |   ДокументОснование.Товары.(
   |      НомерСтроки,
   |      НаименованиеТовара,
   |      ЕдИзм,
   |      Количество,
   |      Цена,
   |      Сумма
   |   )
   |   ИЗ
   |   Документ.ДокументОснование КАК ЗаявкаНаДоставку
   |ГДЕ
   |   ЗаявкаНаДоставку.Ссылка В (&Ссылка)";
   Запрос2.Параметры.Вставить("Ссылка", Ссылка);
   Выборка2 = Запрос.Выполнить().Выбрать();

   
   ОбластьТоварыШапка = Макет.ПолучитьОбласть("ТоварыШапка");
   ОбластьТовары = Макет.ПолучитьОбласть("Товары");
   ТабДок.Очистить();

   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка2.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;

      ТабДок.Вывести(ОбластьТоварыШапка);
      ВыборкаТовары = Выборка2.Товары.Выбрать();
      Пока ВыборкаТовары.Следующий() Цикл
         ОбластьТовары.Параметры.Заполнить(ВыборкаТовары);
         ТабДок.Вывести(ОбластьТовары, ВыборкаТовары.Уровень());
      КонецЦикла;


      ВставлятьРазделительСтраниц = Истина;
   КонецЦикла;

alexandr_ll

Полагаю, что переменная запроса ЗаявкаНаДоставку и параметр Ссылка обращаются к разным документам.

Теги: 1С 8.3 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск