Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 июн 2021, 00:20

Печатная форма

Автор freeman09, 27 дек 2016, 10:35

0 Пользователей и 1 гость просматривают эту тему.

freeman09

Добрый день, пожалуйста помогите найти ошибку в коде:
Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   Шапка = Макет.ПолучитьОбласть ("Шапка");
   ОбластьПереченьНоменклатурыШапка =
   Макет.ПолучитьОбласть("ПереченьНоменклатурыШапка");
   ОбластьПереченьНоменклатуры = Макет.ПолучитьОбласть("ПереченьНоменклатуры");
   ОбластьИтог = Макет.ПолучитьОбласть("Всего");
   ТабДок.Очистить ();
   
   ВставлятьРазделительСтраниц = Ложь ;
   
   Пока Выборка.Следующий()Цикл
      
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц ();
         
      КонецЕсли;
      
      ТабДок.Вывести(ОбластьЗаголовок);
      Шапка.Параметры.Заполнить("Выборка");
      ТабДок.Вывести(Шапка,Выборка.Уровень());
      ТабДок.Вывести(ОбластьПереченьНоменклатурыШапка);
      
      ВыборкаПереченьНоменклатуры = Выбока.ПереченьНоменклатуры.Выбрать ();
      СуммаИтог = 0;
      
      Пока ВыборкаПереченьНоменклатуры.Следующий ()Цикл
         ОбластьПереченьНоменклатуры.Параметры.Заполнить(ВыборкаПереченьНоменклатуры);
         ТабДок.Вывести(ОбластьПереченьНоменклатуры,ВыборкаПереченьНоменклатуры.Уровень());
         СуммаИтог = СуммаИтог + ВыборкаПереченьНоменклатуры.Сумма;
         
      КонецЦикла
      
      ОбластьИтог.Параметры.ВсегоПоДокументу = СуммаИтог;
      ТабДок.Вывести(ОбластьИтог);
      
      ВставлятьРазделительСтраниц = Истина;
      
      КонецЦикла

выдает ошибку -
{Документ.ОказаниеУслуги.МодульМенеджера(57,13)}: Ожидается символ ';'

ilyay

Цитата: freeman09 от 27 дек 2016, 10:35
Добрый день, пожалуйста помогите найти ошибку в коде:

выдает ошибку -
{Документ.ОказаниеУслуги.МодульМенеджера(57,13)}: Ожидается символ ';'

Открыть модуль менеджера документа, перейти на строку 57, колонку 13.
Добавлено: 27 дек 2016, 10:59


Цитата: freeman09 от 27 дек 2016, 10:35

      КонецЦикла
      
      ОбластьИтог.Параметры.ВсегоПоДокументу = СуммаИтог;
      
По-видимому, между этими двумя строками не хватает ";".

freeman09

   
[/quote]
По-видимому, между этими двумя строками не хватает ";".
[/quote]
Спасибо, точно, уже глаз замылился, смотрю и не вижу:)
Добавлено: 27 дек 2016, 11:55


Цитата: ilyay от 27 дек 2016, 10:58По-видимому, между этими двумя строками не хватает ";".

и правда)) не заметил, спасибо :ooifh:

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск