Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 09:00
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Не отрабатывает цикл  (Прочитано 1274 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн BlackWolf

  • *
  • Регистрация: 2016-12-26
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
Здравствуйте, делаю внешнюю печатную форму в ЗУП 8.2 не отрабатывает цикл, подскажите пожалуйста, что делаю не так?


Оффлайн BlackWolf

  • *
  • Регистрация: 2016-12-26
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
Код модуля объекта:
Функция Печать() Экспорт

ТабДокумент = ПечатьДокумента();
Возврат ТабДокумент;

КонецФункции // Печать

Функция ПечатьДокумента()

//Получим данные из документа

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| РазовыеНачисления.Сотрудник КАК Сотрудник,
| РазовыеНачисления.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
    | РазовыеНачисления.ДатаОкончания КАК ДатаОкончания,
    | РазовыеНачисления.Результат КАК Результат,
    | РазовыеНачисления.ДокументОснование КАК ДокументОснование,
    | РазовыеНачисленияОсновные.ДатаВыплатыДохода,
    | РазовыеНачисленияОсновные.ПерерассчитываемыйДокумент

    |ИЗ
| РазовыеНачисления.Ссылка.ДополнительныеНачисления КАК РазовыеНачисления,
    | РазовыеНачисления.Ссылка КАК РазовыеНачисленияОсновные
    |ГДЕ
    | РазовыеНачисления.Ссылка = &ТекущийДокумент";

Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект); //используем в качетсве параметра реквизит обработки СсылкаНаОбъект
    ТабличныйДокумент = Новый ТабличныйДокумент;
   
    МакетОбработки = ПолучитьМакет("МакетРазовыхНачислений");
                               
    //заполняем шапку
    ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
    ОбластьШапка.Параметры.Дата = Формат(СсылкаНаОбъект.ДатаВыплатыДохода, "ДЛФ=Д");
    ОбластьШапка.Параметры.Номер = СсылкаНаОбъект.Номер; //выводим шапку в табличный документ
    ТабличныйДокумент.Вывести(ОбластьШапка);

    //заполняем строки ТЧ
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("ТЧ");
   
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.ДополнительныеНачисления Цикл
        ОбластьСтроки.Параметры.ПодразделениеОрганизации = СсылкаНаОбъект.ДополнительныеНачисления.ПодразделениеОрганизации;
        ОбластьСтроки.Параметры.Сотрудник = СсылкаНаОбъект.ДополнительныеНачисления.Сотрудник;
        ОбластьСтроки.Параметры.Результат = СсылкаНаОбъект.ДополнительныеНачисления.Результат;
        ОбластьСтроки.Параметры.ДокументОснование = СсылкаНаОбъект.ДополнительныеНачисления.ДокументОснование;

        ТабличныйДокумент.Вывести(ОбластьСтроки);
    КонецЦикла;

    //заполняем подвал
    ОбластьПодвал = МакетОбработки.ПолучитьОбласть("Подвал");
    ОбластьПодвал.Параметры.Итого = СсылкаНаОбъект.ДополнительныеНачисления.Итог("Результат");    //выводим подвал в табличный документ
    ТабличныйДокумент.Вывести(ОбластьПодвал);

    ТабличныйДокумент.АвтоМасштаб = Истина;

Возврат ТабличныйДокумент;

КонецФункции // ПечатьДокумента()

Оффлайн temrmal

  • ***
  • Регистрация: 2011-11-10
  • Сообщений: 174
  • РЕПУТАЦИЯ: 22
  • КПД: 13%
А в процедуру входит?

Оффлайн BlackWolf

  • *
  • Регистрация: 2016-12-26
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
А в процедуру входит?

Прошу прощения, не совсем понял вопрос. У меня в коде нет процедур, что вы имеете в виду?

Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
Прошу прощения, не совсем понял вопрос. У меня в коде нет процедур, что вы имеете в виду?

тут два варианта.
или не вызывается процедура
Функция Печать() Экспорт
или
СсылкаНаОбъект.ДополнительныеНачисления
- пустая коллекция.

и совсем не понятно, как используется запрос.
Спасибо за Сказать спасибо

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • *****
  • Регистрация: 2011-06-09
  • Сообщений: 562
  • РЕПУТАЦИЯ: 104
  • КПД: 19%
  • Профессия: Разработчик 1С
Не задана связь между двумя таблицами в запросе.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
22 Сообщений
alexandr_ll
15 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск