Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 11:53

Не отрабатывает цикл

Автор BlackWolf, 26 дек 2016, 13:52

0 Пользователей и 1 гость просматривают эту тему.

BlackWolf

Здравствуйте, делаю внешнюю печатную форму в ЗУП 8.2 не отрабатывает цикл, подскажите пожалуйста, что делаю не так?

BlackWolf

Код модуля объекта:
Функция Печать() Экспорт

ТабДокумент = ПечатьДокумента();
Возврат ТабДокумент;

КонецФункции // Печать

Функция ПечатьДокумента()

//Получим данные из документа

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| РазовыеНачисления.Сотрудник КАК Сотрудник,
| РазовыеНачисления.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
    | РазовыеНачисления.ДатаОкончания КАК ДатаОкончания,
    | РазовыеНачисления.Результат КАК Результат,
    | РазовыеНачисления.ДокументОснование КАК ДокументОснование,
    | РазовыеНачисленияОсновные.ДатаВыплатыДохода,
    | РазовыеНачисленияОсновные.ПерерассчитываемыйДокумент

    |ИЗ
| РазовыеНачисления.Ссылка.ДополнительныеНачисления КАК РазовыеНачисления,
    | РазовыеНачисления.Ссылка КАК РазовыеНачисленияОсновные
    |ГДЕ
    | РазовыеНачисления.Ссылка = &ТекущийДокумент";

Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект); //используем в качетсве параметра реквизит обработки СсылкаНаОбъект
    ТабличныйДокумент = Новый ТабличныйДокумент;
   
    МакетОбработки = ПолучитьМакет("МакетРазовыхНачислений");
                               
    //заполняем шапку
    ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
    ОбластьШапка.Параметры.Дата = Формат(СсылкаНаОбъект.ДатаВыплатыДохода, "ДЛФ=Д");
    ОбластьШапка.Параметры.Номер = СсылкаНаОбъект.Номер; //выводим шапку в табличный документ
    ТабличныйДокумент.Вывести(ОбластьШапка);

    //заполняем строки ТЧ
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("ТЧ");
   
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.ДополнительныеНачисления Цикл
        ОбластьСтроки.Параметры.ПодразделениеОрганизации = СсылкаНаОбъект.ДополнительныеНачисления.ПодразделениеОрганизации;
        ОбластьСтроки.Параметры.Сотрудник = СсылкаНаОбъект.ДополнительныеНачисления.Сотрудник;
        ОбластьСтроки.Параметры.Результат = СсылкаНаОбъект.ДополнительныеНачисления.Результат;
        ОбластьСтроки.Параметры.ДокументОснование = СсылкаНаОбъект.ДополнительныеНачисления.ДокументОснование;

        ТабличныйДокумент.Вывести(ОбластьСтроки);
    КонецЦикла;

    //заполняем подвал
    ОбластьПодвал = МакетОбработки.ПолучитьОбласть("Подвал");
    ОбластьПодвал.Параметры.Итого = СсылкаНаОбъект.ДополнительныеНачисления.Итог("Результат");    //выводим подвал в табличный документ
    ТабличныйДокумент.Вывести(ОбластьПодвал);

    ТабличныйДокумент.АвтоМасштаб = Истина;

Возврат ТабличныйДокумент;

КонецФункции // ПечатьДокумента()

temrmal

А в процедуру входит?

BlackWolf

Цитата: temrmal от 26 дек 2016, 22:29
А в процедуру входит?

Прошу прощения, не совсем понял вопрос. У меня в коде нет процедур, что вы имеете в виду?

alex0402

Цитата: BlackWolf от 27 дек 2016, 08:09Прошу прощения, не совсем понял вопрос. У меня в коде нет процедур, что вы имеете в виду?

тут два варианта.
или не вызывается процедура
Цитата: BlackWolf от 26 дек 2016, 14:30Функция Печать() Экспорт
или
Цитата: BlackWolf от 26 дек 2016, 14:30СсылкаНаОбъект.ДополнительныеНачисления
- пустая коллекция.

и совсем не понятно, как используется запрос.
Спасибо за Сказать спасибо

ilyay

Не задана связь между двумя таблицами в запросе.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск