Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 06:01

Проверка и предупреждение пользователя .

Автор Voodoo, 22 дек 2016, 16:12

0 Пользователей и 1 гость просматривают эту тему.

Voodoo

Доброго времени суток.

Прошу прощения , если пишу глупости, я новичек.

Задача в следующем:

Необходимо чтобы при создании документа , если номер не уникален , выводился вопрос в РежимДиалогоВопрос.ДаНет
Если юзер нажимает ДА - создается документ игнорируя уникальность( проверку уникальности встроенную выключил)

Я сделал запрос в котором я получил список номеров :

&НаСервере
Процедура  ПроверкаНомера()
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Договор.Номер,
      |   Договор.Номер КАК Номер1
      |ИЗ
      |   Документ.Договор КАК Договор
      |ГДЕ
      |   Договор.Номер = &Номер";
   
   Запрос.УстановитьПараметр("Номер", Номер);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Если Номер = Объект.Номер Тогда
          //И тут я завис(
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры


Мне не ясно, как дальше вызвать режим диалога, ведь его на сервер не вызвать.

Подскажите пожалуйста!:(

Andrey_Batuev

Цитата: Voodoo от 22 дек 2016, 16:12Подскажите пожалуйста!:(

Неверный подход... Делайте на клиенте с вызовом функции на сервере, которая будет проверять номер и возвращать Истина/Ложь (есть такой номер или нет). А уже исходя из полученного результат открывайте свой вопрос пользователю именно на клиенте.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск