Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 окт 2021, 08:52

Помогите с ошибкой

Автор Grifter, 12 дек 2016, 08:13

0 Пользователей и 1 гость просматривают эту тему.

Grifter

Пишет поле объекта не обнаружено(Цена) при выборе продукции и не высчитывает Всего.
Код
&НаКлиенте
Процедура КоличествоПриИзменении(Элемент)
   Всего = Продукция.Цена * Объект.Количество 
КонецПроцедуры

&НаКлиенте
Процедура ПродуктПриИзменении(Элемент)
   Объект.Количество = 1;
   Всего = Продукция.Цена * Объект.Количество;
КонецПроцедуры

&НаКлиенте
Процедура ЦенаПриИзменении(Элемент)
    Всего = Продукция.Цена * Объект.Количество;
КонецПроцедуры


Продукция.Цена - это путь к данным в форме, но при написании кода Всего не видит значение этого поля.

MuI_I_Ika

Думается мне что Сначала нужно получить текущиеДанные. а потом уже что-то вычислять.

ТекущиеДанные = Элементы.Продукция.ТекущиеДанные;
Всего = ТекущиеДанные.Цена * ТекущиеДанные.Количество

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск