Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 17:43
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Дополнительные внешние печатные формы (Справочник Номенклатура)  (Прочитано 1190 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Grumax

  • *
  • Регистрация: 2010-04-27
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
Стоит задача сформировать значение поля Артикул, по определенной маске. Делаю на основе внешней печатной формы вызов своей формы. Проблема заключается в том, что я не могу понять как обратиться к ещё не записанной карточке номенклатуры. СсылкаНаОбъект тот же СправочникСсылка.Номенклатура, но у этой ссылке нет методов ПолучитьОбъект() и ПолучитьФорму(), а вот когда карточка записана, то всё работает...
#Если Клиент Тогда

Функция Печать() Экспорт

Попытка
//Получаем по ссылке объект
ТекОбъект = СсылкаНаОбъект.ПолучитьОбъект();
//Определяем записан ли Элемент в базу
Если ТекОбъект.ЭтоНовый() Тогда
ФормаОбъекта = ТекОбъект;
Иначе
//Элемент записан в базу, тогда берем по ссылке форму
ФормаОбъекта = СсылкаНаОбъект.ПолучитьФорму("ФормаЭлемента");
//Форма открыта, но проверка не лишняя
Если не ФормаОбъекта.Открыта() Тогда
ФормаОбъекта.Открыть();
КонецЕсли;
КонецЕсли;
//Запуск формы для формирования Артикула по маске и в зависимости от группы
фрмФорма = ЭтотОбъект.ПолучитьФорму("ФормаАртикул");
стрАртикул = фрмФорма.ОткрытьМодально();
//Полученный артикул передаем в форму, далее пользователь записывает её и закрывает
ФормаОбъекта.Артикул = стрАртикул;


Исключение
//Когда нажимает кнопку "Добавить", не могу получить объект, просим пользователя снаячала записать карточку с любым артикулом
Сообщить("Запишите карточку Номенклатуры перед формированием Артикула");

КонецПопытки;

КонецФункции // Печать()

#КонецЕсли


Оффлайн temrmal

  • ***
  • Регистрация: 2011-11-10
  • Сообщений: 174
  • РЕПУТАЦИЯ: 22
  • КПД: 13%
используй не как печатную форму а как обработку заполнения объекта


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 433
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск