Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2021, 08:07
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Выборка и выгрузка всех документов из одной базы в другую - 1С  (Прочитано 1474 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Святослав Балашов

  • *
  • Регистрация: 2016-12-02
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
Здравствуйте, делаю моб. приложение на 1С:Предприятие 8.3 . Хочу выгрузить документы из одной базы(ПК) в другую базу(моб. прил)
Но при выгрузке документов почему то выгружается только один документ, который самый ближайший по дате(например 25 ноября).
Выгружает один документ(ближайший по дате) - нужно все документы выгружать независимо ближайший, не ближайший, а именно все. Как быть? Помогите. Вот мой код:
Операция "ВыгрузитьИзБазы" в вебсервисе "обменДанными" ( база ПК)
Функция ВыгрузитьИзБазы(Код_Устройства, ВидДанных)
   
   
    ДанныеДляВыгрузки=Новый Структура("Дело", Новый Массив) ;
    Выборка=Вычислить(ВидДанных+".Выбрать()");
   
    Пока Выборка.Следующий() Цикл
       
ОбъектДляВыгрузки=Выборка.Ссылка.ПолучитьОбъект();//  объект для преобразования xml
 
Описание=Новый ЗаписьXML;   //создаваемая запись в xml
Описание.УстановитьСтроку(); // вывод в строку
СериализаторXDTO.ЗаписатьXML(Описание,ОбъектДляВыгрузки);  //Перевод в XML
ОписаниеЗаявки=Описание.Закрыть();     //искомая строка с xml описание
 
    ДанныеДляВыгрузки.Дело.Добавить(ОписаниеЗаявки);    // добавляю в структуру
    Возврат Новый ХранилищеЗначения(ДанныеДляВыгрузки, Новый СжатиеДанных(9))   //возврат значение "дАННЫЕ для выгрузки", помещенного в хранилище значения с коэф. сжатия=9.
    КонецЦикла;
 
КонецФункции




Тут я в форме вызываю "все" "Документы" в форме документа "Заявки".(Из Общего модуля - "Данные" - там реализовывал код выгрузки документов(Заявки)) (Моб. база)
&НаКлиенте
Процедура ЗапросЗаявки(Команда)
   
   
    Данные.ПолучитьДело("Дело")
КонецПроцедуры

Здесь уже идёт вызов заявки из вебсервиса(ОбменДанными), реализовывал в общем модуле "Данные". (Моб. база)

Процедура ПолучитьДело(Знач Получаем) Экспорт
    Если Получаем="Дело" Тогда
        ПолучитьЗаявки()
        КонецЕсли    ;
    КонецПроцедуры
   
    Процедура ПолучитьЗаявки()
    Перем ВебСервис ;
    Сервис.Подключить(ВебСервис, "ОбменДанными");
       
Дело=ВебСервис.ВыгрузитьИзБазы(Константы.КодМобильногоУстройства.Получить(),"Документы.Заявки");
          ЗагрузитьЗаявки(Дело);
       
      КонецПроцедуры
     
       
Процедура ЗагрузитьЗаявки(ПакетСДанными)
         ДанныеДляВыгрузки=ПакетСДанными.Получить();
         
 Для каждого ОписаниеЗаявки из ДанныеДляВыгрузки.Дело Цикл
             
        Описание=Новый ЧтениеXML;
        Описание.УстановитьСтроку(ОписаниеЗаявки);
        НовыйОбъект=СериализаторXDTO.ПрочитатьXML(Описание);
        НовыйОбъект.Записать()
         
    КонецЦикла;
   
КонецПроцедуры




Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
69 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
neek666
33 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
25 Сообщений
KATERINA 861
18 Сообщений
Алексей_1985_06
17 Сообщений
SSC
13 Сообщений
alexandr_ll
12 Сообщений
BuhRust
10 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 1
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск