Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 сен 2021, 15:14

Таблица значений не сворачивается(

Автор Aldnepr, 01 дек 2016, 19:25

0 Пользователей и 1 гость просматривают эту тему.

Aldnepr

Задача выгрузить в 3 колонки ТЗ данные из дока, и потом свернуть по первой колонке, просумировав значения в оставшихся двух. Таблица вроде бы заполняется, но не сворачивается не пойму почему. Может потому что сворачиваю по колонке в которой Ссылка на реквизит справочника?

Процедура КнопкаВыполнитьНажатие(Кнопка)
// Вставить содержимое обработчика.
//ДокРозн=Документы.ОтчетОРозничныхПродажах;
ТЗ= Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("УТКВЭД",Новый ОписаниеТипов("СправочникСсылка.НоменклатураГТД"));
ТЗ.Колонки.Добавить("Сумма",Новый ОписаниеТипов("Число"));
ТЗ.Колонки.Добавить("НДС",Новый ОписаниеТипов("Число"));
Налог= Документы.НалоговаяНакладная.СоздатьДокумент();
Для Каждого ТекущаяСтрока Из ДокРозн.Товары Цикл
НоваяСтрока = ТЗ.Добавить();
    НоваяСтрока["УТКВЭД"] = ТекущаяСтрока.Номенклатура.НоменклатураГТД;
НоваяСтрока["Сумма"]=ТекущаяСтрока.Сумма;
НоваяСтрока["НДС"]=ТекущаяСтрока.СуммаНДС;
Сообщить(""+НоваяСтрока["УТКВЭД"]+" "+НоваяСтрока["Сумма"]+" "+НоваяСтрока["НДС"]);
КонецЦикла;
ТЗ.Свернуть("УТКВЭД","Сумма,НДС");

Сообщить("ГОТОВО!");
Для Каждого ТекущаяСтрока Из ТЗ Цикл
Сообщить(""+ТекущаяСтрока["УТКВЭД"]+" "+ТекущаяСтрока["Сумма"])+" "+ТекущаяСтрока["НДС"]);
КонецЦикла;


КонецПроцедуры

sertak

Возможно, причина в дубликатах

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск